No response from server

New user here. I have v1.1.2 on a Mac. When I try to log in to the Library (to install plugins), it says “No response from server.” What am I doing wrong? 35%20PM

You are not doing anything wrong

1 Like

Thanks Yeager. Reading through that thread, looks like this is still an issue for Mac folks?

1 Like

All I know it’s NOT resolved yet, and both mac and windows users are having trouble…

1 Like

I have the same problem from Linux.

i also have the same problem

Was this ever resolved? I have the same problem (3 YEARS LATER) after downloading Rack 2 Free for v. 2.0.6 and 2.1.2…

Did you try to log out and log in again on the website?

I did and it didn’t work, but I have the solution now! I’ll share in the new post below. It’s a simple SSL certificate update that solved it for me.

@joshkrahn, @flying-sheep, @umanghirani2004

I found a solution which worked for me - hope it’ll work for you too.

A support rep pointed me to look at log.txt in the *…\Documents\Rack2* folder. I saw an SSL/SSH error after I tried to log in so I started digging and I located a cacert.pem file in the installation folder (“Program Files\VCV\Rack2Free”) - then I used Firefox to download the SSL certificate for VCV Rack’s API and I appended it to the cacert.pem file. After that I logged in succesfully and updated my library!

A walkthrough below. Let me know any questions. [Windows and I also use Firefox to get SSL cert]

  1. Open VCV Rack and try to log in.
  2. Next immediately go to “C:\Users\user_name\Documents\Rack2” and open log.txt - If you can find a line like this “[30.736 warn src/network.cpp:157 requestJson] Could not request SSL peer certificate or SSH remote key was not OK” it’s likely the SSL trick will work
  3. I use Firefox now because I know how to get the certificate from it and I recommend it, but feel free to use anything else. In Firefox go to and click the lock symbol next to the address in the address bar, then click “Connection secure”: image
  4. Next click “More information” and a new window will pop up. While in the “Security” tab click the “View Certificate” button and a new tab in browser will open.
  5. While is selected scroll down and click the hyperlink “PEM (cert)”
  6. Open the downloaded file in any text editor and COPY IT’S ENITRE CONTENTS
  7. Next go to “C:\Program Files\VCV\Rack2Free” and open cacert.pem file in a text editor IMPORTANT: You need to open this file with admin permissions image
  8. Paste the SSL certificate at the end of the file and save it.

This should work now hopefully. Let me know how it went.


sadly this isn’t working for me on mac. Anyone have any other tips to get things working again?

I seem to be experiencing this right now; Mac OS 14.2.1, VCV Rack Pro 2.4.1

Anybody have any ideas?

Problem solved following @ estevao25 's advice…