Newbie 1.0 port question -- Skylights

It seems like @Skrylar wants to give up maintaining some of my favorite Modules.

So I took a quick run at porting the Skylights modules to 1.0. I’m not a Rack plugin developer, or even that familiar with the Rack APIs, but I can read instructions and decode compiler errors, so I got a 1.0 version of the Skylights plugin to build!

It does not load but it looks like I f*cked something up with the JSON and plugin names:

Could not load plugin ./1.0-User/plugins-v1/Skylights: Manifest contains module What_Note but it is not defined in the plugin

So you could do me a HUGE solid if you can explain to me where the module names are in the source code and what they need to match in the plugin.json file.

Or if you want to give it a go yourself, I have a fork on github with all my changes checked in. Haven’t tried fixing the deprecated warnings yet. I was hoping to see if my unfrozen caveman programmer port to 1.0 worked or not.


Normally at the bottom of each module file

createModel<..., ...>("What_Note")

They need to match the "slug" of each module under "modules": [

Thanks, I fixed the plugin.json and kept it from dereferencing NULL module pointers and it seems to work just fine!

There is a v1 branch on Github where I already did this port (it runs on the compatibility API at time of writing.)

1 Like

Missed this. My fork does the full port.

OK I re-did the porting to v1 work on top of your V1 branch.

This also fixes my boneheaded version of plugin.json so all the plugins show up properly.

I’ll submit a pull request.