My plugins doesn't show up in the plugin version.

Hey :slight_smile:

Been working on some modules for a while now and I wanted to test them in the plugin version of VCV.

But when I open Logic, my modules doesn’t show up in VCV. I tried using Logic via Rosetta and with out Rosette, with same result. I can’t see my plugins.

Is this a notarization issue?

Or is there something else I need to do, for the plugins to work in the VST version?


You installed them in your Documents/Rack2 (2.4.1) or wherever-they-go (2.5+) plugin directory?

if you do an in=place build at dev time you need to install before the plugin version shows them.

“install” being another word for “copy” in the case of Rack plugins :-).


which is what the plugin makefile’s make install is supposed to do (but broken on Windows with Onedrive before 2.5, where that was fixed as part of the move from documents to appdata).

Hey Paul :slight_smile:

I do use make install when I install so it automatically copies them to the Rack folder… I guess I couldn’t use them at all if they weren’t in the right place.

I checked, all the other ones I downloaded from the VCV2 library, they work. But another one I build myself, Lomas sampler does not work either.

So I am obviously doing something wrong.

I have moved the Rack2 folder to another place and using a symlink to link to it. I’ll check if that might be the issue, but again, all the other modules works, except the two I’ve build. So I don’t think that’s the issue, but will test anyway.

I am on Macbook M1, by the way.

Can it have anything to do with that the plugin version of VCV2 only allows modules downloaded from the library? And the plugins are “notarized”, when put in the library?

Cause everything else I have is from the library, these two aren’t.

I don’t have a Mac, so no idea about notarization issues. I seriously doubt that there is any check that modules came from the library - it just scans the file system, just so you can build your own. If you’ve moved the plugin location with a symlink, then make install may not work and you’d then have to copy your built plugin manually. First thing to check is if your plugin is successfully copied to the same location as all the other plugins.

Yeah there’s no signing for plugins

Anything in your log? And your plugin is same version as the standalone you test in?

I do make install and see it in the plugin on my m1 all the time though.

Are you 24 or 25?

Make install works fine in symlink folder, been doing it like that for months, with no issues :wink:

I have checked if the plugins are in the right folder, all plugins show up and works perfectly in stand alone mode. I also only have one installation of VCV2 Pro, so there is no confusion between versions, I’d say.

I’ll check that.

Not sure what that means? :slight_smile:

Moving the Rack2 folder in right place and removing the symlink didn’t do anything either.

Are you running vcv rack 2.4 or 2.5? With 2.5 the folder moved so if you are using the 2.4 SDK with the 2.5 runtime it may install in the wrong spot, was my thinking.

1 Like

Ah, that’s what you ment :slight_smile:

I am on Rack 2.4 and I am using the SDK I got when I installed 2.4. So I am pretty sure that’s not the issue.

1 Like