MPE in VCV 2 Pro is very buggy yet

Hi patchers, I have a problem. Do I have unique experience or it’s a common problem?

So. First I tried standalone VCV 2 Free, tried to load any of my MPE patches, and they didn’t loaded properly just because moDillz MIDIpolyMPE is not ported to 2.0 yet.

Okay, let’s make a new MPE patch only with built-in VCV modules. I made it from MIDI CV, VCO, VCA, ADSR, SUM and AUDIO output. Very simple, and any possible third-party bugs are excluded. And… All gone bad. Pitch slide doesn’t work. Neither on V/Oct out, nor on PW out. MW doesn’t output, so I workaround it with CC-CV on 74cc. Aftertouch works. Okay, I would be happy to mess around without poly-pitchbends for a while, but VCV stops react to notes very soon.

Then I purchased Pro. With a slightly hope that hosted VCV may sort any of those problems. And this situation (no PW, stops react to MIDI notes) is reproducing on both standalone and ableton. I’m not asking for refund or something, I really glad this dope is finally hosted, so I can export my generatives in ableton in any resolution. But MPE problems upsets me.

I’m using Sensel Morph with Buchla Thunder overlay, factory layout.

For sure, MIDI-CV module has properties set: Polyphony mode: MPE Polyphony channels: 4

MPE on VCV instance is enabled in ableton.

We can only wait - and perhaps write a word of encouragement (and/or donate).

Here Any plans to migrate to VCV Rack v2? · Issue #24 · dllmusic/moDllz · GitHub

Don’t think it will be fixed/added in VCV modules soon. Very few use MPE. But I can’t be sure.

I don’t have full MPE hardware - only an CME Air 25 with poly aftertouch.

problem is not only in existance of MIDIpolyMPE. Even vanilla patch crashes after less than a munute of playing even in standalone

When it comes to MPE, both Abeton Live and Bitwig (and maybe some other DAWs too) are doing some “damage” to the incoming MIDI data, e.g. channels are rearranged and values are smoothed.

I own a LinnStrument and I am actually working on an MPE module that fits my personal needs.

And yes (at least on windows), flooding Rack V2 with MIDI data can cause a crash.

Oh, I didn’t use MIDI much yet in 2.0x

I’m building Rack from git with current rtmidi, to see if that makes a change.

dep/Makefile diff
$ diff Makefile.orig
< rtmidi-4.0.0:
<       $(WGET) ""
<       $(SHA256) rtmidi-4.0.0.tar.gz 370cfe710f43fbeba8d2b8c8bc310f314338c519c2cf2865e2d2737b251526cd
<       $(UNTAR) rtmidi-4.0.0.tar.gz
<       rm rtmidi-4.0.0.tar.gz
> rtmidi-5.0.0:
>       $(WGET) ""
>       $(SHA256) rtmidi-5.0.0.tar.gz  c0f57eca5e7ebc8773375d5e9f56405d2b37a255a509fa57d2dc4f7e87d2c564
>       $(UNTAR) rtmidi-5.0.0.tar.gz
>       rm rtmidi-5.0.0.tar.gz
< $(rtmidi): | rtmidi-4.0.0
<       cd rtmidi-4.0.0 && $(CONFIGURE) $(RTMIDI_FLAGS)
<       $(MAKE) -C rtmidi-4.0.0
<       $(MAKE) -C rtmidi-4.0.0 install
> $(rtmidi): | rtmidi-5.0.0
>       cd rtmidi-5.0.0 && $(CONFIGURE) $(RTMIDI_FLAGS)
>       $(MAKE) -C rtmidi-5.0.0
>       $(MAKE) -C rtmidi-5.0.0 install
< src: glew-2.1.0 glfw jansson-2.12 speexdsp-SpeexDSP-1.2rc3 openssl-1.1.1k curl-7.79.1 zstd-1.4.5 libarchive-3.4.3 rtmidi-4.0.0 rtaudio nanovg nanosvg oui-blendish osdialog
> src: glew-2.1.0 glfw jansson-2.12 speexdsp-SpeexDSP-1.2rc3 openssl-1.1.1k curl-7.79.1 zstd-1.4.5 libarchive-3.4.3 rtmidi-5.0.0 rtaudio nanovg nanosvg oui-blendish osdialog

“make dep” throws an error and doesn’t complete. Probably more than I can fix.

had to add “-lstdc++” to LIBS in “dep/rtmidi-5.0.0/tests/Makefile” - have to figure out how to do this the right way.

Well guys, in 1.1 built-in module MIDI-CV could send polyphonic pitchbends. But in 2.0 can’t.

Please report your findings to VCV

1 Like

yup, completely unusable on the Mac as well, in both standalone and vst.

(and yeah, not just MPE, Ive also had a sequencer crash vcv by sending ‘too much’ midi… very disappointing)

I reported to support, complete with stack trace, not heard a word back.

I have found that ODDSOUND MTS-ESP can handle polyphonic pitchbends. Only CC to Midi seems not to handle polyphonic pitchbens…


I check this module and it also doesn’t output poly pitchbends (VCV2.0, Windows, both ableton and standalone).

Did anyone succeeded? Maybe I’m doing something wrong? Or any magic pill checkbox in VCV’s preferences?

I can’t believe that poly-pitchbend problem can situate that deeply in core