Module doesn’t show up in brand list in Module Browser


I’ve been a professional developer for more years than I care to admit. I haven’t worked a lot with bare metal languages like C++ for a while but it used to be my bread and butter a decade or so ago so I don’t need my answers sugar-coated or anything.

Anyway, after a year or so of using VCVRack and actively looking, I’ve finally found a couple of itches that are both simple enough to be a first VCVRack plugin project and don’t seem to have existing plugins readily available already.


I’ve read the dev tutorial, and while it raises at least as many questions as it answers, it at least got me to the point where I’ve written some code that compiles and make installed it.

I can see my sitting in ~/.Rack/plugins-v1 - but when I run Rack 1.1.6, my module doesn’t show up - my “brand” isn’t in the “brands” list of the plugin search tool and I’m not sure how else to find my newly written module.

What am I missing here?

Double check that you’ve populated plugin.json correctly, that catches a lot of newbies out (me included).

Thanks - but define “correctly”.

Potential issues with my plugin.json:

  1. all the *Url fields are blank.
  2. The “Tags” list is empty. (Edit: added a tag - no difference)

Everything else looks reasonable to me. What are the subtle gotchas?

(Edit: My plugin.json was generated by - are there required fields NOT populated by

Please don’t use useless titles for posts such as “Newbie help”. This makes the forum index a mess. Edited with better title.

Noted, and thanks for the edit.

Most probably forgot to uncomment your module in plugin.cpp.

On the one hand, yes, that was the issue - I can see my module now. (Thanks heaps!)

On the other, I take issue with the term “forgot” - unless you can show me where in the developer tutorial that step is mentioned.

1 Like
To enable the module, add
extern Model *modelMyModule;
to plugin.hpp, and add
to the init() function in plugin.cpp.