Midi out of VCV VST in Studio One

Hello there! Is anyone using Studio One? Last night I tried to duplicate problem someone was having and posted about here on the community page where the midi someone was getting out of Instruo’s Harmonaig was being read incorrectly in Ableton by another midi track where the poster was capturing the midi data.

This is not what my question is about though… My trouble is that I could not find a way to access the CV to midi output in my instance of VCV at all. Taking midi from the track and applying it to another was only able to steal the midi input from that track (controller and midi clips), but I could find no way to see the midi data being gathered by the midi to cv module and direct it to anything in drop down menus for midi sources for input on tracks.

I have VCV’s Host modules so I am not really worried about having this functionality for myself, but it would be nice to know if it can be done and how so I could help others out if they run into the problem in the future and I happen to read that they are having trouble. Who knows? Perhaps somewhere down the line I stumble on some generative sequence that inspires and confounds me and I would like to look at the midi from it for analysis as well.

Thanks for responses in advance, successful or not. :slight_smile:

I use Studio One pretty much exclusively, but have had a fair number of problems with VCV Rack integration :frowning: (haven’t been able to get the VST plugin working yet).

However, in part of my troubleshooting experiments, I did get VCV Rack receiving MIDI from Studio One, with the S1 transport running on a MIDI track. It crashes all the time (so maybe I’m doing it wrong?), but I can usually get it to run for a few minutes. Here’s what I had to do:

  • to be safe (trying to avoid weird looping issues), I opened “Audio MIDI Setup” (I’m on a mac), created a new port under “Core MIDI” and called it “Keyboards”
  • in Studio One 5.4, did the usual: Preferences → Ext. Dev. → “Add …”
  • in the dialogue window, I chose “New Instrument” set it to receive from the main port on “Core MIDI” and send to the new “Keyboards” one I created (I also enabled all the check-boxes, minus MPE)
  • on the MIDI track, I set the instrument to the new one just created, updated VCV Rack to listen to the “Keyboards” port and it works great until it crashes (not sure if the MIDI track being on loop causes issues?)

As a bonus, with those check-boxes and with this setup below, when I press “play” and “stop” on the transport, the clock module in my patch also starts and stops:

1 Like

Quick update: there were multiple events in my MIDI track, so I merged them (Studio One menu → Events → Merge Events) and haven’t … well, sod it – just crashed again. But! It played for much longer before doing so this time (1.5 loops of the track). :man_shrugging:

1 Like

Your replies are appreciated, but the thing I am trying to do is get midi out of VCV to another track (like to run another VST with sequencers from VCV). Not on a MAC but I would assume there is a windows equivalent of CORE for routing midi inside computer, but outside the DAW. Seems like a good bet for temporary solutions anyway. If all else fails and I actually feel the need to do it (I expect to mostly use VCV standalone still, to get out of the DAW mindset), I can always rout midi out of the computer and record a midi input, then time correct. Perhaps VCV just needs an update for in-Studio One midi routing? There are lots of DAWs to consider how they handle things.

Good Luck to you in your trouble shooting and thanks again for the notes.

1 Like

Ah, after-rereading, I see …

I suspect I can’t fully grasp + test what you’re doing, since it seems like you’re trying to bring MIDI … back into VCV? (the one hosted in the VST plugin?) Not sure …

Anyway, just in case the reverse of what I showed earlier is useful: I just set up VCV Rack to send MIDI to the appropriate system device / port (the “Keyboard” one in my case) – sending both the v/oct as well as gate: Screenshot 2021-12-29 at 10.07.15 PM

Then, in Studio One:

  • created a new external device, this time “New Keyboard” (not “New Instrument”) and named it “CV MIDI”
  • chose the desired system MIDI device in the “Receive From” dropdown
  • checked all the filter boxes
  • created a new track, assigned it an instrument, and selected it from the drop-down in the track

Screenshot 2021-12-29 at 10.14.37 PM

The instrument in the DAW started playing the sequence from VCV Rack immediately … maybe something in those steps is useful?

1 Like

Yep, something like this is likely to work, it’s just that I am on PC and have no Core equivalent to assign the cv to midi module to, so that i can create the device that S1 will see. I’ll have to do a smidge of research to find one and maybe make a purchase. Thanks again!

1 Like

Actually I think I am wrong… I have “Windows MIDI”, which appears to be the core equivalent. You may have solved my issue here with your last post. Sorry that I can’t return the favor.

1 Like

I have had a lot of success routing midi from VCV in Studio One. I’m not sure if it helps your situation, but I just add a cv-midi module in VCV and choose a midi channel for the output. Then on the target instrument track I want to send midi to, I just choose the vcv plugin (not track) as the source for midi input and then the specific midi channel. This works well for being able to access all 16 midi channels coming out from VCV on seperate tracks. I just keep the cv-midi device as DAW and that works just fine. I’ve even set it up so I can record midi on several channels from a generative piece then feed it back into VCV rack.



1 Like

Thank you very much! You have solved my problem in a strange way… I went to see what the difference between choose the plugin and not the track was and while I could find no tracks to choose (just the plugins and controllers I have), I just ended up spending enough time figuring out my user error. lol I was just highlighting vcv to start what I was trying to record which set vcv’s track to be the one recording instead of the empty track I was trying to record to. It being my first time trying to get midi from one track to another I just didn’t notice the record enable shutting off. I can lock that on the mixer panel… all problems solved. Thanks again!

Thank you sir, as it turns out I was just missing a minor detail, and studio one routs internally just fine. I grabbed that program anyway. Seems like it could solve other problems or allow for syncing other software should I find myself wanting to in the near future.

1 Like