Midi mapping bug

Hi all,

I got touchOSC installed on my ipad and am trying to map layouts to vcv. Page 1 sends cc1 to 40 on channel 1, page 2 same but on channel 2, etc etc. My issue is channel number is ignored when receiving midi, so I end up having one fader in touchOSC controlling 2 or more params in VCV. Tried with stoermelder midi cat as well and i got the same problem which makes me think it’s an issue with vcv. Already made sure the ipad is sending the right messages, no error on my part assigning cc# and channel#.

I have 5 or 6 pages of knobs and faders to map so I’m easily exceeding 128 different cc numbers, definitely need to use more than one channel of midi… Anybody run into that problem?

You can try my MIDI-MON module and check the incoming MIDI messages. I’m pretty sure it is a wrong setting in touchOSC or its MIDI driver but I have no experience with these.

Checked with midi mon and protokol a midi/osc logger by hexler. channels and ccs are assigned correctly.

Please post a screenshot or provide a patch. Many use touchOSC with Rack without any problems.

first 2 screenshots are midi cc number and channel of message

exemple patch.vcv (133.6 KB)

problematic modules are in top right corner of the patch, but this happens with any module. need grayscale and impromptu.

MIDI-CAT in the top right corner of the patch is set for “All channels” MIDI channel input and channel 1 MIDI feedback. Is this set intentionally?

No, a misclick I think. edit: channel 1 is chosen by default

I’m not sure I understand. By default “All channels” is selected for any MIDI input control and “Channel 1” for any MIDI output control as there is no “all channels” for MIDI output. This is true for MIDI-CAT and the VCV MIDI modules, I did not check every 3rd party module.

That would just affect midi feedback though, which is not the problem. If I use fundamental midi map module it’s the same result. I found a workaround, I need to setup a midi cat or midi map module for each channel…

Ah ok, I think there is a misunderstanding. The slot (in MIDI-CAT and MIDI-MAP) does NOT learn the MIDI channel, the channel is only filtered by the setting in the display. If you leave it at “All channels” the module will respond to messages on any channel.

Oh god… sorry I did not know that. Thank you for the help!

No problem. Setting up one module for each channel is the right way to go.

1 Like