Mac / Big Sur / vcv not receiving audio from Ableton 10.1.30

Hi, Hope everyone is well and keeping safe… I’m at my wits end trying to get midi from ableton into vcv and then back again into ableton using cv tools (cv instrument). It was working fine but has stopped working (I was getting crackles etc).I am using blackhole (mac) as an aggregate sound device. I have tried removing rack and reinstalling and also deleting the aggregate device and readding… I can get sound from vcv into ableton no problem (using a basic sine from a vco into the audio 16). But I cannot get any flashing gate and cv from audio 16 into vcv. In cv instruments (ableton) it seems to sending impulses etc but not being received in the appropriate ports of audio 16. I have also tried readding the microphone permissions in privacy etc as per a previous post to no avail. If anyone has any suggestions it would be greatly appreciated - please keep them clean though :slight_smile: Mucho gracios Daz

You say you are using Blackhole as an aggregate device. What are you aggregating it with and how many channels does it have? It may be that your Blackhole Channels are higher than the 16 maximum of Audio-16.

Just for clarity, the LEDs on Audio 16 won’t flash - they are just either on or off to show if a channel is active/available. You need to plug cables in to see if there is anything coming out of them.

And of course, as you mentioned, Rack needs permission to access Microphone otherwise you won’t get any audio coming into it. Perhaps post a screen grab of you r microphone permissions settings showing Rack is checked there, then once that is eliminated, be specific what you are aggregating with, how many channels it has, what your audio out device is in Ableton settings, and what channels you are sending out of Ableton on.

1 Like

Hi Steve, Thanks for the reply. It is appreciated… The blackhole is aggregated with my laptop speakers and also the laptop headphones. 1-16 out are blackhole 17-18 laptop speakers 19-20 headphones 1-16 in are blackhole

I did have a go at changing the audio from 16 to 8 but made no difference… Yes, the leds dont flash or go solid green (nothing). This is the issue… All the best Darren

Steve - when I click the cv on the vca it produces a sound so I know it is sending sound fine. It just isn’t receiving it…

Hmmm - that is weird as it does all look like its set up correctly.

A couple of things to try…

  1. In your Microphone security preferences, uncheck Rack, then check it again (this happened to me once and doing that fixed whatever the issue was)

Change you aggregate device so that the laptop out is 1 & 2, headphone 3&4, and then the Blackhole 16. It might help if a ‘real’ device is the main device and then the others (with the drift correction) follow that.

I’m not confident either of these 2 things will work, but they are all I can think of right now and they are what I would try if it was me…

Also, can you post your ableton audio preferences window please? Need to make sure the Output device there is your aggregate device.

Another thing to try - in your CV instrument channel in Ableton, turn monitoring from auto to off and output from Master to Sends Only

Hi Steve. Tried the untick Rack a few times without success. Deleted and readded aggregate device with headphones and speakers before blackhole.Shut down (rather than a restart). Still no joy… Tried the other suggestions…(as pictured). Still no joy. I’m beginning to understand why it’s called blackhole now :slight_smile: Thats where my audio seems to be…

I have changed the audio to blackhole in ableton and in vcv. It still isnt flashing. I reckon it has to be blackhole ;op

It’s working! Hurray. I added a multi output device and added both the blackhole and headphones. Thanks for your help though, as I say it is very much appreciated. I can now get on with hurting my head and wiring bits up now ;op


What do you mean by a multi output device?

I had a look on github as well (thats where I got this…)

Oh OK - that’s weird…

A multi output device is used for MIRRORING audio to more than one destination. In this case your CV/Gate will be going to blackhole, but it will also be coming out of your headphone out…

Looking at the GitHub docs, the built in audio does need to be the first device in an Aggregate device when used with Blackhole