Lomas Modules 1.0.9

I uploaded a new version of the modules. You can download a preview version for windows at:


thanks! I’ve noticed before that in the Gate Sequencer choosen method of reset (right click menu) doesn’t save its state when the patch was been closed. Can you fix this too? I’ve just found something like default reset mode = 0 in your code and change to = 1 and it works for me, but maybe will not always work for other users. Thanks!

Thank you Lomas. You seem to have solved my / the DC offset bug and all the samples play now without weird clicks :+1: The Module grew a bit in size 2hp? but that is not a problem, the old patches will load even with the bigger skin.

But… the “new” sampler does not reload the “old” settings, none of the buttons/knobs are recalled and none of the samples. Was it your intention not to make this, as we windows users say/know/love, “Backward Compatible” ?

You use mode 1? I was going to remove that option but i will keep it & fix it.

There is a discusion on VCV Github about how sequencers in VCV should handle reset.

Mode 0 is how VCV sequencers should work. The sequencer resets instantly. Then ignores clock signals for a milisecond to avoid a “bug” you must have seen. The first step is not played.

Mode 1 is how it works in the Nord Modular. The sequencer resets at the next clock signal, not when getting the reset pulse.

I love the “next clock input” setting on the gate sequencer it does exactly what I want.:+1:

“Instant” skips the first beat , so which one is 1 and which one is 0 ?

Sorry about that Yeager.

I did not think about preset compatibility when doing then update. Is something to keep in mind for the future. It may be possible to do something before pushing the update to the library. But I am not sure. I am not used to this things sorry.

Instant is how a classic modular hardware sequencers works and how Vortico says VCV sequencers should work.

Next clock input is the Nord modular way. I put it because it works better for me when I used with Valleys Topograph.

Next version the VCV way will be the default mode and the module will save the user option.

That would be nice :grinning:

So my favourite sequencer setting is NOT the vcv Vortico way…:thinking: But the Next clock will be selectable right ?

Mac version anyone please?

I uploaded a new version to Github.

The sequencer now saves the reset mode.

In Sampler I implemented something to mask the clicks when rettrigering samples.

I don’t have a mac so I can’t compile it. I will post it on the Facebook group to see if anyone can do it.


These are really well done and a nice addition to the library. Thanks!

1 Like

Uploaded a new version to Github. Mostly bug fixes and make the sampler more stable.

Did you get a Mac version?

1 Like

No Mac version at the moment sorry.

thanks! envelopes work awesome now. wondering about stereo version as well)

Stereo version is planned after rack 2 is released

1 Like

Would having the envelope shadows* on the waveform display be something that could be added? Could only be present when not in loop mode as loop mode reacts to the envelope differently.

*the shade that gets added to the ± pos.x behind/in front of the start and end positions that is.

I tried to draw a line with envelope level over the sample but I did not like how it looks. I will try your idea about shading the envelope level and see how it looks.

1 Like

Is it a bug or a feature? Found that if the Attack set to value 1, means full clockwise the Sampler module goes silent? After reducing this value the module works as expected again. I am on Mac so its the last available version from the library.

I just checked and looks like a bug.

Awesome modules! I noticed that a Gate Sequencer uses the clock of the Gate Sequencer to the left if they are adjacent. I couldn’t find any documentation that makes this behavior explicit, but is there a way of disabling this if we want more than one Gate sequencer positioned together in the rack, but want to use multiple external clocks?