Less CPU hungry VCV Rack alternatives?


(Joebentley10) #61

I’ve tried it at various FPS limits, block sizes, and audio thread counts and I have to admit I’m not seeing a significant improvement at any block size. Interestingly the audio thread count seems to inflate the remaining mS available but it doesn’t seem to help. For example at 30fps with 512 block size I’m getting a tonne of stutter but sitting at around 350 mS with 2 threads. Even so with 1 thread I’m at >150 mS consistently yet I’m still getting a tonne of stuttering.

It seems definitely helpful, but not enough to get my MacBook to work with this patch right now


(Jim T) #62

on a dual core, adding threads just won’t help anything. hyperthreading also doesn’t help.

I’ve not worked out the math for mS display, it gets somewhat warped with multi threading, especially around the audio module.

it’s a shame that FPS limiting hasn’t helped, let’s keep plugging away.


#63

I’ve been trying out the multithread version (totally distracting me from working lol), and on my 2017 MBP I can use framerate 30 and 3 threads to get what seems like much better performance, at least I’m able to screen record video/audio and patch/modulate/wiggle without glitching. Temperature is showing 137, however, the fans are not screaming atm. I do have the MBP on a cooling pad (which from what I read doesn’t help much at all).

I am interested in trying this out on my pc laptop as well and observing what happens.


Audio Interface/Sound Card?
(Patman / NYSTHI Manual) #64

I hope that’s °F?


(Patman / NYSTHI Manual) #65

I won’t lie, a full year seeing @Vortico online, and I still can’t get a read on serious/sarcastic from him at times… :wink:


(Patman / NYSTHI Manual) #66

@JimT I don’t -think- I saw much about it on here yet… Think the experimental build might help out a 2 year old AMD quad-core A10-9600P 4C+6GPU?

If it’s any kind of benchmark, Valley Plateau runs about 120-150 miliSquirrels, and Frozen Wasteland Portland Weather about 1400 mechaSqueaks (which reminds me, I need to figure out bug reporting on the Klirr Factory PW - I never got it to load ever)


(Jim T) #67

You’ve got 4 cores, so it might do something. However, PW taking >1000 squirrels probably won’t run given any number of cores, looks like it’s taking longer than 1 sample time to process 1 sample and the MT patch can’t make an individual module run multi-threaded. The only hope for PW is faster single core performance, but once you’ve got that, you can run the other modules on a different thread using the MT patch whilst PW takes up its own core.

Reducing FPS might help out too (in some voodoo, unspecified way).


(Patman / NYSTHI Manual) #68

Wouldn’t be surprised on the FPS front, nuking vu meters always helps (now if only I could kill plug lights…)


(Joebentley10) #69

This is definitely helping hugely on newer patches I’ve been making. I think maybe Dexter was causing a lot of issue for me.

Biggest benefit is that on 30fps my fan is not going anywhere near as mental and it doesn’t feel hot at all, which was a huge issue that would start pretty quickly after adding even a small number of modules!! So thanks very much @JimT :smiley:

Another thing I discovered that improves performance greatly to me is Squirky Labs’ Thread Booster. On my mac this makes it so I can actually browse chrome with VCV Rack running my music without unbearable amounts of stuttering. On real-time i actually get no stuttering no matter what I do but chrome sometimes hangs, but I don’t mind that. Definitely a life saver module I wish I knew about!

Here’s my first proper patch with this new VCV Rack. Thanks again @JimT! 8th jan.vcv (82.8 KB) (don’t forget to hit reset on CLOCKED to make sure everything is running, thread booster is to the right of Audio if you have issues with it)


(Joebentley10) #70

It occurs to me I’m using samples in the above, so it won’t work, give me a second…

EDIT: Here’s a version with autodafe drums: 8th jan autodafe.vcv (82.6 KB)


(Artem Leonov) #71

Windows 10, core i5-2500k - 30 fps and 2 threads - awesome perfomance! thank you for this mode Jim!


(Antonio Tuzzi) #72

can anyone try with this MOD the “7Seas” module ?
the 7Seas in SWARM is a CPU eater.

using contextual menu you can put it in bgnd process, or in the main engine process and check what are the performances


(Antonio Tuzzi) #73

the other superCPU intensive is the “DeepNoteGenerator” (60 oscillators + 150 envelopes)

on my MacBook pro i7 2011 I hit 280 mS in release mode


(Jim T) #74

I have this on in the background whilst I work


(Joebentley10) #75

Nice :smiley:


(Nik Jewell) #76

I’ve never used SevenSeas and don’t have time to figure it out right now. I can maybe try tonight.

DeepNoteGenerator is ~240mS on the i9 MBP.

I don’t think this is the right box to be testing on though as I am in the ‘overheating MBP’ group, not the ‘old machine’ group, of possible beneficiaries of Jim’s mod. The multithread mod might help an old machine that is struggling with it, whereas I benefit from being able to reduce the GPU frame rate.


(Jim T) #77

Deepnote works fine in multithreaded. Adding it to joe’s patch does cause stuttering on my windows laptop just before the crescendo. Adding a second thread lets it run cleanly. I can’t give meaningful figures on 2 threads as the cpu counters get a bit screwy - I haven’t adjusted their math to account for the extra threads. It won’t use more or less CPU, it just runs deepnote on the extra thread and is fine.

FPS limiting has no effect.

Forcing 7seas to run on the engine thread is much the same story. Although I haven’t figured out how to get a sound from it yet. It’s current sitting on ~60mS, it’s happy getting processed with an extra thread.


(Antonio Tuzzi) #78

OT: to load table data in 7seas, just drag and drop a directory containing the tables.

a full set of tables are here
https://waveeditonline.com/wav-files.zip

unzip it, and drag and drop the unzipped directory on 7seas (or load via context menu)


(funkブラスタ) #79

With my SevenSeas experience I will say I used to have mS issues but for some mysterious reason not anymore. If i see some stutter in the module i just set its block size to 512 samples and boom! no more annoyances!

To quote the VCV manual:

Rack measures the amount of time spent processing each module in mS (millisamples). This is a unit of time equal to 0.001 / {sample rate}.

To maintain a stable audio clock, the total amount of time spent processing all modules must equal 1000 mS . To achieve this, the Audio module from Core uses your audio device’s high-precision clock to regulate Rack’s engine, so it idles for the remaining mS until this total is met. If the Audio idle time falls close to an average of 0 mS over its block size, an audio stutter may occur. This can be caused by other modules consuming lots of mS.

I’m no audio engineering junkie but from my experience, I think it’s talking about the fact that using a metric ton of mS (which apparently is a time measure) can cause noticeable slowdown in the patch itself, due to the power hogs preventing the sound to get in time. But dang if I know fully about processing time and all that stuff.


(Nik Jewell) #80

Seven Seas on i9

Low, Medium, HCF: 6,7,8ms. non multi 56ms
Swarm 9 on Medium, 84ms with multi turned off

I get stuttering on 16 block, fine on 32 and above.