Knobs don't work properly on Ubuntu 20.04

New developer here. First step on Ubuntu 20.04 LTS, install Rack. Then, Rack knobs don’t work properly. They stick at one extreme or the other, on all modules that I tried. This is a straight install of Rack with no changes.

Any clues?

Wild guess: are you in a VM? Mouse handling can be a bit odd there. Try unchecking “View / Lock cursor while dragging”.


Yes. That fixed it. Thanks. I would never have figured that out.


@andrew.bernard @Richie I’d like to get more details about this and edit the original title so that it’s more clear.

What kind of virtualization leads to this issue? does this only happen on Ubuntu virtual machines or any Linux virtual machine? what OS is hosting, Mac or Windows?

(btw - are there any reasons to run Rack in a virtual machine rather than running the native executable file?)

I can only speak for my setup, which is Ubuntu 18.04 in VMWare 15 on Windows 10 - that has this problem. I don’t know about any other setups.

The reason I run Rack in a VM is for testing the Linux versions of my plugins. If I were just using Rack rather than developing for it, I’d just run the Windows version.

1 Like

There is some config setting I always forget. Something about mouse capturing curor?

Scroll up a bit. :slight_smile: “Try unchecking “View / Lock cursor while dragging”.”

Doh! Sorry.