It Works: Using Reaper, ReaRoute, Beat Step Pro

After nearly 3 weekends I’ve finally exhausted my options, and to use Reaper, and ReaRoute. I tried using ReaRoute with Mixbus but couldn’t get it working, and Cuckos Forums stated it wouldn’t work.

Currently, I’m in Reaper, ReaRoute works well for recording audio. But I’m having issues getting my Beat Step Pro working with ReaRoute ASIO driver. As with Omri’s videos, he’s using Audio OUT from the BSP to the INPUT of the interface. I’ve connected Clocked BPM to Core Audio IN with ReaRoute ASIO as the driver but the clock doesn’t moved.

What else do I have to configure to get this working?

Steinberg UR22 (First Gen)
Beat Step Pro

Reaper 64 bit
Latest VCV Rack

In conclusion, I want to use Beat Step Pro in VCV Rack while recording the Audio with ReaRoute into Reaper.

Hi Justin!
Let me see if I get it right. You want to send the clock from the BSP to VCV and you’re using Reaper and ReaRoute, right?
How do you set it up in Reaper?
I’m doing this all the time and I would love to help you with this. Can you send me a screenshot?

Omnri, thanks for replying! Yes I’d like to send the clock from BSP to VCV while recording. I am using Reaper, and ReaRoute. Sending the clock from BSP to VCV works when Yamaha Steinberg ASIO driver is enable. It works well. But not when using ReaRoute and Reaper while trying to record.

Here’s some screenshots:

I suppose I could just not sync the clock from BSP to clocked, do it manually, and create some music. But the transport-like controls - manipulating the clock from the hardware while using ReaRoute ASIO in VCV Rack would be way better than doing it manually

Using the Yamaha Steinberg ASIO driver, BSP can control clocked with no issues. Using ReaRoute does not allow the clock to move.

I think I know what the problem is. In Reaper, do you have a separate track for the clock? Let’s say that the clock is going into input 1 on you interface, then the track in reaper should be set to input 1. Make sure also to set it to monitor and arm for recording. Then, click the I/O button on this track and under Audio Hardware Outputs, add ReaRoute 1 for example. Now, the clock should come out of output 1 in VCV. ***** VERY IMPORTANT!!! In the same I/O window, unselect Master Send so the clock doesn’t go to your monitors/speakers/headphones ******
Please let me know if this works for you.


Holy crap, it works. You just made my evening. Thank you so much dude! I owe you a lot of coffee, or beer. Or something. Thank you sir.

1 Like

Hey nice! Great :slight_smile: I’m really happy it works! I should make a video about this also, I’ve been wanting to do this for a while now… Anyway, now don’t forget to share some sounds with us :wink: Cheers!


+1 for a video on this topic :smiley:

1 Like