Issues with resizing Rack's window

so as the title says, the rack disappears when I stretch the window out past ~1600 pixels horizontally. this is mostly an annoyance, though it does prevent me from using it in fullscreen. nothing resolves the issue except resizing it back to ~1280 pixels wide or so (this is happening on a second monitor running at 1080; the laptop’s native screen resolution is 1280x800).

any ideas?

osx 10.7.5 / vcv 0.6.3c
x3100 GMA / opengl 2.1

edit: did some testing, and the horizontal window size at which it blacks/unblacks the interface is arbitrary. sometimes it will disappear around 900 px wide, sometimes close to 1900 – and sometimes I can’t get it to revert at all without closing and reloading the program.

are you trying to stretch the window to span multiple monitors? also, what’s the second monitor’s resolution?

Post a screenshot?

negative, just trying to full-screen it on a monitor attached via mini-dvi to my older macbook. the second monitor is 1920x1080.

I would, but it would just be the vcv interface window filled with black (aside from the top menu). it changes to all-black as I extend the window horizontally, then reverts to showing everything as it normally does when I shrink it back to ~1280 pixels wide.

Can confirm wierd shit happens when you move VCV Rack from one monitor to another. Moving back to the original monitor restores it back to it’s original look. It’s not the positioning of the controls that move, but background image/labeling. They retain their scaling from the original monitor when moving to a new monitor. Here’s the wierd thing, all my monitors are 1920x1080. So it’s not the resolution itself. I have 3 monitors on this PC. 2 external monitors, +1 laptop monitor. This only occurs on the laptop monitor. (The default monitor is one of the external monitors.


same for me on windows 10, 1920x1080, hdmi monitor. But it doesn’t appear on laptop’s monitor…

Don’t we yet have a solution for this issue?

Neither of my desktop systems has any issues with this, and they are both dual 4K.

This issue is more likely related to the OS tying the Rack process to a specific graphics processor. There was another thread around here recently about that.

1 Like

Either that, or the monitors are running with different scaling. Windows let’s you specify a scaling for each monitor, and lots of applications struggle to cope with moving windows between scalings.

You could test that by setting all your screens to 100% and seeing if the problem goes away. But that wouldn’t be a long term solution

1 Like

GLFW 3.3.3 have some interesting word on this

Thanks guys, yes the issue was both fitting screens to 100% and I had to change the graphic settings for the rack to high performance to cope up with it.

1 Like

Will there be a fix for scaled windows? Or a way to refresh?

I have a similar problem on MacOS 12.6 : When I move it to me second screen :

If I move it back to my other screen it’s fine :

Is there still not a way to refresh without closing / reopening ?

The first issue (drawing incorrectly on a second screen) is imao a bug. Have you reported it?

Have you tried to zoom out and then in again, to see if it fixes the graphics glitches?

Zooming does not solve the issue, I haven’t reported it yet but I will, thanks.

I’m guessing that one of your screens has retina and the other doesn’t.

1 Like

Same here, 2 different monitors (resolutions), as only I move VCV (v2.2.2, AU plugin) window to the other monitor or switch applications, VCV is unusable (module redrawn in such a way that I don’t see what I’m doing). VCV has to be restarted. I’m on OSX 12.5. I’ve sent it to support but this bug seems to be unresolved for a very long time…

Same problem here on a Mac mini M2 with 2 monitors (QHD and 4K) Problems occurs on the 4K (where there is a retina scaling). The only way to work on the 4k I’ve found is to put the app window on the good monitor, quit and relaunch so that the app opens on that monitor. (but if i move it to the other monitor back and forth, it bugs again) (tested with vcv rack 2 pro standalone, not the VST yet)

edit: Similar problem within Live 11. When I open the vst on the 4K → Ok but when I move it to the QHD it bugs. I have to delete the vst from the track and put it anew