Issue when editing Multitrack recording from VCV in a DAW

Hello Everyone !

I have been using VCV for a few month now, and really love it, so first, thanks to all the people developing great modules for it, this is amazing !

I have an issue since a while and I couldn’t find a solution after looking in the forum, there was a thread about midi jitter and latency that goes a bit in this direction, but I think this is something different. If there is a post about this already then feel free to delete my post !

So, My Problem is, that after making a multitrack recording, when I import the Tracks in my DAW, to edit them and add more virtual instrument or external gear on top on top of my recording, I can’t align them perfectly with the grid My method to align files after recording normally is to set up the tempo in the DAW, jump to a clear transient (From a defined signal, like a Kick for example), make a cut on all the files at the point where this transient is, then select all the file and move them to the beginning of a Bar. I am using Logic Pro X and Pro Tools, and I have encountered the same problem in Both DAW : When I Move the files, they seems to be aligned at the beginning, but the tempo is actually slowly drifting. At the end of a 8 min File, there is a difference from a few milliseconds between transient and beat. I did a test patch with screenshot to show you better what I mean recording only a kick on every beat at 111 BPM during 8 minutes

The patch : The Kick from VCV drums is triggered by the DK drum Sequencer, wich is receiving a clock from Clocked. The Audio Signal From The Kick is going to the mindmeld 8 Tracks mixer and being recorded through the Poly Outs of the Polyrecorder by Nysthi.

Here is the position of the kick at the beginning of the Project (The playhead is on a beat to see the position of the kick relative to a beat)

And here the kick at the end of the project (The playhead is on a beat to see the position of the kick relative to a beat)

I suspect that the DAWs and VCV does not use the same number of ticks per quarter note and interpret the tempo slightly differently. I know where I can set the Ticks per quarter Note In Logic, but I don’t know if there is a way to do it in VCV, or if it is different from clock modules to clock modules. Or maybe someone know wich number of ticks per quarter note VCV if using ? Then I could use this number in Logic. I have done this test with and without my interface and got the same results so the problem does not seems to come from there… My solution right know is to beat map every bar to the grid, and I feel like (or Hope !) there is a better way to fix this. I am looking forward for any idea, if someone has a clue about what is going on here !

Thanks for your time !

Best Regards,


Config : Mac M1 Mac OS Big Sur 11.5.2, Tascam Model 24, Logic Pro X version 10.7.0

it’s always been like this. the clocks are just a little off. the longer the recording the more drift by the end. its one of the reasons i’m looking forward to the vst.

Pro tools and VCV can both use Ableton Link (you don’t need Ableton Live to use Link) - try using the tempo from Link in VCV.

Don’t know about Logic Pro.

yes looking forward for the plugin as well !

wow that’s a good advice, thank you, I will try this !

Or try a VCV LFO square wave for a clock, perhaps it uses higher precision than CLOCKED.

Set the frequency to 1.8500 Hz (111 bpm / 60 s/min )


1 Like

Unless your DAW and VCV are actually hard synced together, you will always get some drift over time if you are just setting them to the same BPM. The longer the time, the more the drift. You would likely get the same thing between two different DAWs or any other two audio applications. BPM is simply not that precise a value.

The answer is to sync VCV to your DAW ideally using a 24ppqn audio clock pulse from the DAW into Clocked’s BPM input. This will not just set a BPM for clocked, it will create a constant hard sync between the two and will keep them running perfectly in time. Or you can use Ableton link which does something similar.


Thank for your answer, I will try sending a clock to clocked BPM input !

Once you connect an external clock, you use the mode buttons on Clocked to set the ppqn value of the clock it is receiving - so with a 24ppqn clock you would press the mode button a few times until it says P24.

1 Like

Thanks everyone for your fast and great answers, it is nice to see that the community is so active ! I ll try the three methods out asap and will let you know the result !

So synced Clocked to Logic by sending a clock from Logic throught a IAC Bus and grabbing it from the VCV module Midi to CV, It was working except once in a while, it seemed like the clock was missing a beat and then coming back on track, but I will play with the setup of the VCV midi to cv module, it might come from there. Thanks a lot for your help, that’s already a step to a better sync !

I have tried the Ableton Link as well, for some reason it also does not sync perfectly all the time, but its not slightly drifting like before tho, its more like sometimes a little off grid and then comes back on track. I might try to mix this method and the one from Steve, and send the clock out from Stellare to the clocked BPM in 24ppqn mode. Thank you for your help ! I will try the LFO method to and keep you updated :slight_smile:

There’s a module with a clock smooth function which sometimes helps with these kinds of things - I think it’s ML modules.

Edit: yeah it is:

1 Like

Thanks, I will Try it out as well :slight_smile:

Yeah, incoming MIDI is not very reliable in Rack V1, that has been fixed for V2 though. Instead try and send the sync. clock through a (maybe virtual) audio interface, from the DAW to Rack, that’s rock solid!

1 Like

Cool, good to know that this has been fixed in V2 ! I will try sending it to am interface first, thanks for your time :slight_smile: !

1 Like

I think these are related:

1 Like

My procedure has been:

  1. exported multichannel broadcast wav files.
  2. Edit the multichannel wav file to begin the file on beat (i.e. remove silence before downbeat.
  3. split them into separate wav files for each channel and imported them into Live using Wave Agent
  4. Import into Live, and set tempo to the VCVRack patch tempo (as generated by Clocked)

I’ve found that Clocked’s tempo and Live’s tempo are very, very close, so much so that even over 10 minute tracks, they stay locked, or close enough not to matter.

Hi, thanks for your answer, it might be due to logic and pro tools then, I do exactly the same you described but I Use Logic or Pro tools… seems like Live goes better along with VCV !

Oh yes thanks ! that would explain why its fixed in V2 then :slight_smile: I guess ill just wait for the new version and stick to beat-mapping for now !