is there a way to open VCV always with blank template?

Is there anyway to force Rack to always open with a blank template?


delete all modules, save the empty patch as a template?

1 Like

you mean , do not open the last session? I would like that too I afraid is not possible

That’s what i’m after, yes.

Had a feeling you couldn’t but always worth asking.

Thanks @Nils and @David.

Change your shortcut to Rack to include the patch you want to open, e.g.

“C:\Program Files\VCV\Rack1\Rack.exe” “c:\Users\paul\Documents\Rack\blank.vcv”

Then when you run the shortcut it will open that patch.



a similar thread from the past

@PaulPiko wouldn’t this result in saving over the blank.vcv file the first time you press ctrl+s?

1 Like

Sure. You’d need to ctrl-shift-s before you ctrl-s :wink:

Maybe set the blank.vcv to read-only before you use it.

1 Like

Finish with a File > New patch then when you quit it saves that and will open with a new blank patch.

That’s what i’ve been doing.

I’m doing the following (on Windows 10 Pro):

  • Create a Rack shortcut on the taskbar
  • Start the Rack software
  • Open with the File menu every specific vcv panel (i.e: Empty.vcv, Mixer.vcv, Tools.vcv) I want to open regular
  • With right click on the taskbar Rack item, I see the recent opened vcv files and pin the specific ones on the list

So I can open Rack with the last patch by click on the taskbar Rack item, or with right click on the taskbar Rack item I can select one of my pinned initial panels. The initial panels are read-only to protect against overwriting. Normally Windows software grumbles with a ‘Save as’ dialog, if You want to save a read-only file. But VCV Rack doesn’t … it saves a tmp file, but doesn’t overwrite my original starting panel. And this is perfect for me :smile: From time to time I remove temp/tmp files anyway.

btw: The tmp file is a vcv patch file, so modify the file name and extension … just in case.

Just as an idea :sunglasses:

1 Like

it might be a good idea to at least leave some audio8 still in there as due to some bug vcvrack might eat a lot of cpu if no audio interface is defined in some situations

Maybe I’m misunderstanding the question, but woudn’t you be able to do what you want by:

  1. Making the template.vcv file a blank patch in the Rack binary directory, and
  2. Modifying the start-scrip to delete the autosave-v1.vcv file in the user Rack directory upon start-up?

Of course, it wouldn’t auto-save for you anymore, but the autosave behaviour in rack is a little counter-intuitive IMO, so that wouldn’t necessarily be a bad thing.

why do you thing it is counter-intuitive?

Most software asks you if you want to save your work if you try to quit with unsaved changes. Rack doesn’t. It just saves the state instead, restoring it when you log back in.

It’s different behaviour then most, so it’s counter-intuitive to me. It took me a little while to adapt my workflow to it, as I would come to a point and think “hmm, this isn’t working. I’ll just quit and log back in to restore my last “good” save.” Rack doesn’t quite work that way.

Autosave is its own file but when you save an opened autosave it overwrites a concrete patch, that you have possibly forgotten by the time you are there to press ctrl+s.

To be clear, I like the fact that Rack doesn’t question me when I want to quit, but I want it to prompt me when I’m manual saving the first time after opening the autosaved state.

1 Like

I am hoping someone could offer some knowledge that I have been unable to locate using our friend Google. Is it possible to turn off autosave? I have tried changing “autosavePeriod” in the settings-v1.json file to zero but it doesn’t seem to stick. I am also curious about having a blank template loaded each time. I have recently run into several occasions where a patch has crashed VCV Rack and, because the file was autosaved, I could not get it to load again. In all cases I have been able to determine the cause of the crash but have, on a few occasions, had to recreate the patch from scratch.

Are you editing settings.json while Rack is open? You need to close Rack before editing this file.

To save a template patch, choose File > Save template. You can delete all modules from your patch and save it as the template patch.


Ahhh. Thanks. I was editing while rack was open. Sometimes it’s the simple stuff that gets you.