Instruo Saich behaves oddly over time? (No - it was user error)

I’m experimenting with the Instruo Saich module in V2 (Windows), and I’m getting some odd behavior that makes no sense to me. I’m mostly using VCV Pro 2.06 on Windows, but briefly tried V1 and got similar behavior.

With a freshly initialized Saich module, all the controls work fine for me, as do all the CV inputs. But as I continue to press the Ctrl and Mix Profile buttons, I eventually get to a state where the effect of the slider control no longer matches the color coding of the buttons. Also the CTRL CV input ceases to work entirely.

If I initialize the module, then everything returns to normal.

I have not figured out any specific combination of button presses that kicks off the behavior.

Has anyone else run into this problem?

Yeah. I had a similar experience where I was unsure if things worked as intended with the button and slider. But I put that on me being the issue :).

At first I also suspected I had a misunderstanding. But then when the CTRL CV input completely ceases to function I can only assume there must be a bug.

<sarcasm>Let’s hope that’s not an accurate model of the hardware unit</sarcasm>


Never mind - user error. I did not read the manual close enough, and did not realize the slider and CV CTRL input can be set to control different things - I thought they were supposed to be in sync with each other.