Impromptu sequencers: new bug or just me?

Has anybody encountered problems lately with the first step on Impromptu sequencers? Omri Cohen recently showed two techniques to get Gate-Seq-64 to reliably generate a gate on the first step (Patreon Q&A \\ February 2023 - YouTube), but those techniques don’t work for me anymore. In fact, using either technique (with Clocked or CLKD as clock), both Gate-Seq-64 and Phrase-Seq-16 omit outputting a gate on the first step, on every attempt, even though I can see the first step lighting up.

I know Impromptu released an update recently and I’m wondering if that may be the cause, or whether this is something specific to my system. (I’m running Rack 2.3.0 on Linux using Jack; overall it works great.) Impromptu has some great modules and I’d like to be able to keep using them. Has anybody else noticed this?

Can you post a screen shot of your patch showing the clock and sequencer connections? The ideal connections require the use of the RUN cable between the clock and sequencer. Here is the related section in the manual to see more on this:

Well, that was fast! Here’s a screenshot:

Looks like there is a bug in the latest update, I tried your patch above with both the before and after versions, and it was missing the first step in the “after” version. I’ll take a look at what might have caused this, thanks for reporting it.


Hey, you’re welcome. Let me know if you need me to test anything. I have a Github account, I can file a bug report and post test results there if need be.

1 Like

Excellent, we can continue there if needed, I have opened the issue. Thanks for offering to test, we’ll see how it goes, but it should be a small thing.

1 Like

This is now fixed in the source code, I’ll be requesting a library update very soon. If anyone wants to build from source and try it though, it would be very much appreciated.


Hi Marc, if you want, I’ll can compile Impromptu for all platforms. Please advise me! :wink:

Merci Dom, I was only mentioning it in the sense that I’m not sure this needs for me (or a kind soul like you!) to make and distribute the builds, the change is so minor, but just for compleness sake, if one person can build locally for them and try the patch shown in the picture further up, and confirm that the first step is played properly, that would be great. I tried it myslef obviously and the fix works, so this is just out of an abundance of caution. Cheers!

1 Like

Ok Marc, I understand! :wink:


I’m not currently set up for Rack development and for building plugins, though I may give it a try… If I reach any proper results, I’ll let you know. And I’m willing to test a Linux build if somebody provides one.

Excellent, thanks. It should be pretty straightforward, following the info here (which you likely have seen):

All right, I made and tested a Linux build and the bug is gone for me. Got a warning and a couple of notes while compiling Write-Seq-32 but it seems to work OK. (The resulting file is much larger than I expected: is that because it’s a debug version, or because of the way I built it somehow?)

Nice to hear, thanks for reporting back :slight_smile: Yes, that has all the debug info in it, if you make dist it will bundle the plugin and strip all the debug info.

Ah, yes, that worked. And since then I’ve been able to get the new version from the library. Thank you for fixing this promptly.

1 Like

My pleasure, and thanks for the bug report :slight_smile: Cheers!