I'm trying to make & install a dummy module to test my setup...

Hi there, If I run ‘make’ or ‘make install’ from my $RACK_DIR I get ‘No such file or directory’. Could this be the formatting in my plugin.json?

I think there are many, many places where I could be going wrong - so thank you for your patience… I’ve had a brief look at the page on jq but frankly I’m hoping someone will be able to confirm yay or nay as whether this is my problem. I know it’s not a promising start to be confused at such an early stage but I really want to be able to program modules and your help is very much appreciated. Here is the contents of my plugin.json…

  "slug": "MyModule",
  "name": "BJGA0001",
  "version": "2.0.0",
  "license": "proprietary",
  "brand": "Plugins by Muggins",
  "author": "BJGA",
  "authorEmail": "",
  "authorUrl": "",
  "pluginUrl": "",
  "manualUrl": "",
  "sourceUrl": "",
  "donateUrl": "",
  "changelogUrl": "",
  "modules": [
      "slug": "MyModule",
      "name": "Test001",
      "description": "",
      "tags": []

I am working in MSYS MINGW32 (started by typing ‘MSYS’ in the start menu) on Windows 11. Thanks, Ben

For one thing I think you need to start mingw64 not 32. (MSYS2 x64)


Good point. Thanks!

Every time I run MSYS it just says ‘mingw32’. I will have to look into how to change this…

In your start menu there should be this :


Choose the bottom one.


Are you following these steps?

1 Like

Thanks. That is bound to have helped. ‘make install’ seems to have made and populated (at least partially) a folder called ‘dist’ now. I’m not sure what the problem with ‘res’ is though…

I’m not an expert (of anything) but maybe it’s not smart to have the working folder in the dropbox cloud ?

Do you have a “res” directory with an .svg in it ?

Never mind me , just read Paul’s next post :+1:

1 Like

I don’t use the SDK, I use a full rack build, so I’m not sure if this is different. In a full build, your plugin is in (RACK_DIR) /plugins/myplugin and you run make from there, rather than RACK_DIR. Or, you run make plugins to build your plugin and any others.

If you want a minimal working plugin for reference and to troubleshoot your build process separately from your code. you might try cloning the GenericBlank: Template for a VCV Rack Blank module (github.com) project. Once you can build this project, you’ll know that your build environment and folder layout is what is expected. Once that’s out of the way, you can then focus on the issues with your project (rather than the build environment).

Of course, you can clone any plugin project, but some have custom build processes that could be a distraction. This one has nearly no code to build, so the build itself is very fast, allowing you to iterate faster in your troubleshooting.


I’ve done it! That red rectangle is my module! It doesn’t look how I wanted it to but my brand ‘Plugins by Muggins’ appeared in the list and that, then, has to be the module. For me successfully compiling and installing anything at all is a MASSIVE step forwards for me… Thank you Peter and Paul and all other correspondents XXX (I moved my MyPlugin folder into a new folder ‘plugins’ and ran ‘make install’ from that folder as Paul suggested, then after a few more hacks in plugin.cpp…

1 Like

And here is my module in all its glory (after, duh, matching the svg name in the cpp with the svg name in the res folder :-))) This makes me very happy :-)) That’s a hare, btw, drawn over the existing svg.

1 Like

Luckily for us Mary was sick today, or the outcome could have been something completely different. :wink: