How to sample a sound which is from a PC


I would like to try some sampling, and from sound which are produced on a PC when browsing. So, sound from « in line » on a PC.

I know how to import a MP3 or sound formats in different modules in VCV Rack. But how to import from in line (I’m not sure about how to name that…)

Thanks for any ideas! Alain, Fr

1 Like

As for getting input from the audio input (microphone or whatever) on your computer, it’s a matter of using the input jacks on the Audio modules. For capturing system audio output (which I think is what you’re after), what you do is likely going to be dependent on what OS you’re on.

If your audio devices include “Stereo mix” then that’s probably what you’re looking for:

If it doesn’t appear, it might be that you have to enable it via Control Panel / Sound / Recording:

If it’s not there at all, probably your sound drivers don’t support it. I don’t know what you’d do in that case.


Maybe this can help.

1 Like

Try searching the forum, there was a post about this a few days ago:

Is that what you’re trying to do?

you need LoopBack , either on the hardware side of your audio interface or via software , if you want it live or for recording it.

you can use OBS to capture desktop audio too .

If it was a Mac I would suggest installing BlackHole. It was the only way I could get audio to record along with screen captures of Rack patches.

Thanks! I will try it.!

Hi Richie,

I’m back in VCV Rack, stil using your sequencers of course ;0)

About my problem, you were right. I didn’t have the PC mix input on the Audio module. I just had to enable it in the config. Thank you for your help! Now I have the option in the Audio module. But I don’t have any signal, or may be very low. I don’t see any signal on a scope…


I have to try. thank you!

Now that works! I had to understand correctly all these configs and drivers…

I discovered something strange (for me) while sampling:

  • With an VCV Rack Engine sampling rate of 44 khz, and same frequency in VCV Audio setup, the result in the sampler is completly crashed. Like if I used a huge distortion…
  • At a lower rate as 22 khz, that works perfectly.

I have a MSI with an Intel(R) Core™ i7-10875H CPU @ 2.30GHz. I think about a sort of crash of the CPU due to too much load? What do you think?

Alain, Fr

I’m glad you have it working! To avoid the distortion you’re hearing, make sure that the system sample rate matches the one you’re using in Rack:

This app in standalone mode. 19$
Rolling Sampler


I checked, and they match. Something else happens…

The only other idea I have is to try any different drivers you have in your list - WASAPI vs. DirectSound, etc. Beyond that I’m afraid I’m out of ideas.

Thank you! I don’t know anything about these drivers on W11. It’s time to learn for me ! :grinning: I will tell you. Alain