how to have vcv 0.6 together with v2 on Mac m1

Hi all, I’d like to explore my old vcv 0.6 songs made on my old Mac. I’m now running V2 on Mac M1, and I have downloaded 0.6 again. problem : where should I put the files I have downloaded? How can I recover all the modules I was using then? For now, I can open rack v.06, but there are only the basic modules. Thank you in advance fo your help!

Which files? Downloaded from where?

I tried myself. Downloaded the and got Rack 0.6 up and running. Logged in, clicked “Update plugins” and… nothing. In the log it says “warn src/plugin.cpp:407] Request for community manifests failed”. Seems like Andrew has deliberately or accidentally changed the library API so it’s no longer possible to get 0.6 versions of plugins.

There’s a bitter lesson here: As with all other software, hang on to your downloaded files when possible because you never know when they’ll become unavailable at the whims of “the cloud”.

I’m afraid that if you don’t have a backup of your old Documents/Rack/plugins/ directory you’re out of luck. Sorry about that.

BTW, did you try if Rack 2 can still open your old patches? Of course some of the modules you used might now be unavailble but maybe you can reconstruct/rescue some of them.

Same download. Can’t update plugins. I still have my old Mac that I run sometimes just to have fun with my ancient songs. It’s sad that all this work is unreadable on my new Mac. I have tried to copy some songs piece by piece from v0.6 to v2 having both computer running side by side. It’s tedious and the result is aaalways different!

If you still have the old patches, and you still have the Documents/Rack/plugins/ directory on your old Mac, then you simply need to copy them over to the new Mac and you’re done!

1 Like

Woaw! I’ll try this for sure! thank you

1 Like

Sure thing, let us know how it goes. If I were you I would simply copy over the entire Documents/Rack/ directory to the new Mac. Then you have the settings, the patches (presumably) and all the downloaded plugins, in one fell swoop.

I am sure I still have the folder, but my patches are all over the places… Should I reunite them somewhere in the same directory ?

Well that’s up to you of course, but it makes it easier to find them, and it’s especially a good idea, I think, to have patches in a folder-hierachy underneath the Rack directory, so you know which version of Rack the patches were made with.

1 Like

great tips! thank you Lars!

1 Like


Following Lars suggestion, I “ressuscited” my old Mac in order to copy the ancient Documents/Rack/plugins/ directory into my new Mac.

But I am still confused…

If I double click on an old vcv file in my new Mac, it, of course, tries to open it in vcv rack 2, which does not work. (" The document “keiwrayy.vcv” could not be opened. VCV Rack 2 Pro cannot open files in the “VCV Rack Patch” format.)
Then if I right-click the old vcv file and choose the application to open it, VCV Rack 2 is the only choice. Should I also have to copy the VCVRack 0.6 app from my old Mac application folder into my new Mac app folder?

That is a wellknown issue of VCV vs Mac: you cannot open a file by doubleclicking it. You need to open VCV Rack first and open the patch with Cmd-O or the menu-item File->Open.

1 Like

Yeah sure! I remember now. Since I have my new Mac I only use VCV Rack as a plugin in Ableton, so I forgot. But still, my question remains intact.

Forgot what you wanted to do. Yes, when you’ve copied over the whole of the old Rack 0.6 directory incl. plugins and settings, you also need to copy over the old 0.6 Rack app, because the whole point is that you want to use your old patches in the old Rack. I don’t actually remember if it’s possibel to open 0.6 patches in Rack2, if all the plugins are still available, they might need to go through Rack 1.x first.

It kind of works, but many modules are missing. I liked your idea of copying vcv 0.6 folder from old Mac into new Mac, but the app itself is missing. May I copy it also in new mac’s application folder ?

Yes, you should be able to just copy it over, and then right-click and select Open.

hmmm, on my mac they open fine when double-clicking. I didn’t do anything special, just works…

It does! I’m surprised. This used to be a problem.

So after double checking my messy folders, I logged in, update the library, and it works! of course some of the key modules seems to be missing :slight_smile: but I’ll find some replacement. Actually I tried to open an old patch in VCV 2 pro, the very first time it opened up nicely, the following attempts gave me error " The document “villa4.vcv” could not be opened. VCV Rack 2 Pro cannot open files in the “VCV Rack Patch” format. and I still get the first patch loading and playing (nicely) anyway…