How to disable tooltip for encoder?

Hi,

Is it possible to disable (entirely) the tooltip for encoder while mouse cursor is over it? (SvgKnob)

For this specific module, the tooltip overlays/hides a small segment-LED display.

This tooltip over encoder (in this case) is useless.

image

No effect from configParam by using “” or by removing last parameter.

And by using NULL instead of “”, the module & rack crashes.

Thanks in advance.

I’m not sure I understand exactly where you are hovering your mouse when this happens. You mention SvgKnob, but is it that big knob toward the top, or something else?

While hovering the big knob (it’s an encoder).

I can’t place elsewhere the small display below the tooltip. The encoder sets the volume level (it have also other features). And the mini display (indicating 50 here) is covered by the tooltip!

image

OK, I don’t know the answer for this, but at least I understand now. Unless somebody else jumps on this and can answer it quickly, I will look through the VCV Rack source code tomorrow and see if I can spot a way to disable the tooltip entirely.

Solved! (reply by Paul Bacon, below).

The tooltip is created in param widget on enter and on leave

First thing I would try is overriding them and on hover to consume and have enter and leave not call parent enter and leave

Too late to try it but that’s where I’d start

5 Likes

PERFECT !!! :ok_hand: :ok_hand: :ok_hand: :ok_hand: Thanks a million, Paul

// Freeware "Moog-style" continuous encoder (main encoder).
struct QPCS_Encoder : SvgKnob {
	QPCS_Encoder() {
		minAngle = -1.0 * M_PI;
		maxAngle = M_PI;
		setSvg(APP->window->loadSvg(asset::plugin(pluginInstance, "res/components/QPCS_Encoder.svg")));
	}

	void onEnter(const event::Enter &e) override {
	}

	void onLeave(const event::Leave &e) override {
	}

	void step() override {
		ParamWidget::step();
	}

};
2 Likes