How can I make Rack look like a "real" app in Ubuntu Studio?

I recently scored a Toshiba laptop with Win 10 for a pretty good price, and so naturally the first thing I did was get the Windows partition to scooch over and make room for a Win/Ubuntu dual-boot system. A big ordeal, but it worked. Yay! :partying_face:

I installed Ubuntu Studio Version 20.04.3 LTS Focal Fossa (Xfce Desktop). Then I downloaded Rack 1.1.6 from VCV Rack - The Eurorack Simulator , unzipped it, and it seems to run okay, at least so far with a few “hello world” patches. Again, Yay! :partying_face:

However … Rack does not appear anywhere in the “Whisker Menu” of apps; in order to launch it I have to drill down through “/home/john/Rack/” (if I remembered where I put it, and not to be confused with "/home/john/.Rack/ "); and when I do find it, it just has a generic “gear” icon, even though a proper C-with-a-dot icon png is sitting there in “/home/john/Rack/res/” .

I also cannot create a link to it to put on the desktop because double-clicking on that link only gives me that familiar error message: “Rack’s resource directory “./res” does not exist. Make sure Rack is correctly installed and launched.”. (I get the same thing on another system with Ubuntu Mate v. 18-dot-something.)

Is there a better way to install it and have it be more easily accessible like all the other apps? The installation part of the VCV Rack manual simply says “Installing on Linux – Unzip the zip file”.

I have seen other people recommend installing MenuLibre to configure the launch menu.

As it turns out, I downloaded that already. It does do almost all of what I had in mind. I find it odd that it showed up in the original menu as “Menu Editor”, but when it runs it calls itself “MenuLibre”. I managed to get Rack included in the menu. Points for that.

The original Whisker Menu was all nicely sorted into different categories of apps, but now most of them got dumped into a single “Multimedia” category. It’s gonna take me forever to sort them all out again, especially since I don’t have a clue what most of them do yet. They have whimsically non-descriptive names. :face_with_symbols_over_mouth: AND you cannot simply drag one or more names into a different category. You have to select one and keep pecking at the down or up arrow (in MenuLibre) to shift each one past dozens of other app names.

It doesn’t look like I can easily undo it to get a screenshot of the original hierarchy. Ah well.

[later] PS.I was able to use MenuLibre to correct its own name in the menu. :hammer_and_wrench:

I don’t use XFCE myself - I usually go with KDE or I3.

This page may have further tips you can use.

You just need to make a .desktop file

e.g

Open up a terminal window and type: nano ~/.local/share/applications/VCV.desktop

Paste the following code into the editor with ‘control + shift + v’

[Desktop Entry]
Type=Application
Name=VCV Rack
Comment=Modular Synthesis
Icon=/home/john/Rack/res/icon.png
Exec=/home/john/Rack/Rack
Terminal=false
Categories=Audio;Music
Keywords=Music
Path=/home/john/Rack

Close nano by pressing ‘control + x’ and then press Y to save

That should then automatically pop up in any app launcher

Yi use to make an script to run the rack, and I run the script with a launcher in the menu (also the script launch jack first, then rack) and I added the VCV rack icon to the launcher , voila!

This looks promising too. Thanks.

Yup. It worked. Now I can run it from the desktop or the Whisker Menu, and it has a proper icon. (As does “Linux Show Player”, which lacked one before.)

:partying_face: :fireworks:

[edit Nov. 15] And with some effort, I managed to create a separate one for Rack 2. Yay.

Part of the difficulty was from not actually completing the creation of the desktop file in nano. When I used CTRL-X and Y to save it, it didn’t quite finish and only saved it as “VCV2.desktop.save” (or something like that). Eventually I spotted the line where you have to hit the ENTER key, at which point it renames the file. :sweat:]

Awesome!

:slight_smile: