Help! Rack plugin toolchain for cross compiling to MacOs.

I followed the instructions for setting up the environment; I extracted quite a few “MacOSX11.1.sdk.tar.xz” files, from 2 different MacOses with different versions: from the, from the command line tools, from the .dmg file (only available for the command line tools, not the whole thing); I also extracted one using Linux Mint (based on Ubuntu) from the .xip file, and I also tried a couple of net found ones as well… no matter what… building the tools for Mac always fails at the same spot: when building apple-libtapi I get a linker error:

/usr/bin/ld: cannot find -lstdc++: No such file or directory

What am I doing wrong? The Linux and Win. parts build and work fine. Trying to build everything using Linux Mint 21.3.

EDIT: I re-read your message, I see you allready tried that - I don’t know then.

Don’t waste your time trying the “net ones”. They don’t work.

Are you building natively or in the Docker environment?

I recommend you use the Docker environment to build and run the toolchain, because it eliminates the effect of potential issues in your host system that could affect the toolchain build.

I haven’t tried Docker, I will :slight_smile:

1 Like

The docker env. Worked, thanks :slight_smile:

fwiw, I build all four types in my native linux build (no docker). I just followed the instructions and it worked. I guess I’m lucky.

That’s kind of what I wanted; but too many hours and cycles lost with no success. The docker build might have given me the clue as to why: apparently, llvm no longer builds libc++ by default. Oh well, it works now.

yeah, I agree, why waste time on this stuff. Luckily my wife has a mac I can harvest sdk from, etc…