Has anyone narrowed down the sends and returns bug?

I heard @Omri_Cohen mention this in a video recently and have just experienced it using MindMeld. There are certain unknown conditions where having sends/returns set up with a mixer can cause Rack to output silence but an apparent constant signal through the aux channels. It is very similar to this bug which is making me think that it is either the same bug somewhere in a plugin or it is something in Rack itself.

I’m just wondering if anyone has managed to narrow down the problem. I always seem to get it either loading a patch (although I haven’t experienced this for a while) or in the middle of noodling and something causes a high output, such as a filter resonance too high. I think it has been suggested that it’s a bug in Plateau, which would certainly fit for me, but I think I’ve seen people experiencing the same thing with NYSTHI’s reverbs.

2 Likes

it happened for me yesterday with the @Squinky.Labs Mixer and Sangster from @heapdump as the send effect. Reloading the patch 1 or 2 times solves it, also removing and re-adding Sangster solved it too.

I’ve never had this problem with Plateau tho.

For me it’s always on load, never in the middle of noodling.

I’m on windows 10, Haven’t tested on Ubuntu Mate ( since my linux computer is a potato which dies after one voice :upside_down_face:)

1 Like

Well that’s useful to know, I suppose, that it happens on Windows 10 as well as linux (me).

I don’t know if it is Plateau that causes it for me as I have experienced it with @synthi’s reverbs as well but Plateau is generally in my patch as a send.

I’ve tried to trace the problem by looking at where the constant voltage originates but it doesn’t seem to come from anything consistently. I did just get it from messing around with Sangster though.

1 Like

I get that no sound w/ constant voltage issue a lot on reloading a patch. Seems like it’s always starts at Rings or Lindenberg stuff going into nysthi mixers. I just duplicate the module and rewire a couple times and it goes back to normal. Been happening since v0.6, so I’m used to it now, but yeah I wonder if it’s a VCV or module issue, or both??

1 Like

Curious if it is still happening in Rack 1.1.6 since the random number bug was fixed. My VCV Rack seems to be more stable since the fix. Hard to know exactly how many modules were affected by the bug and now may be fixed.

Happened to me this morning with MindMeld. Switched back to Glue the Giant, and that’s working fine. (Rack v1.1.6). There’s some constant (inaudible) output from the stereo out of the mixer, with nothing on the main VU. I neglected to look at it in a scope. Might try that later.

There was a bug with a random function generator in Rack 1.1.5 that many modules called upon - particularly Noise modules. This bug meant that occasionally those modules would output infinity. When that happened, it would likely crash other modules further down the chain - often mixers as most things get plugged into mixers! As the output of infinity would happen only when a particular random number was generated, the audio crash could happen anytime from almost immediately to sometimes after an hour or more. This bug has supposedly been fixed in Rack 1.1.6

There was a bug in the first GitHub release of MindMeld MixMaster that caused some channels to be silent when opening a saved patch. This bug was fixed very quickly. If you are finding you have this problem, make sure you are using an up to date version - the version in the plugin Manager is fine.

We are going to add some input clamping to the next version of MixMaster to try and protect it from extreme signals output by misbehaving modules…

If you are getting a repeatable crash with Rack 1.16 and MixMaster, please let us know and ideally provide the minimum possible patch where the crash happens and we will investigate. :slight_smile:

1 Like

Hi schebi

I’m a little confused by your comment “There’s some constant (inaudible) output from the stereo out of the mixer, with nothing on the main VU. I neglected to look at it in a scope.”

If you can’t hear it, can’t see it on the main VU and didn’t look on scope - how do you know it is there?

I had a patch with MixMaster and a FrozenWasteland bpm lfo that did go silence everytimeI started the ZZC clock module. That was cured by deleting the FrozenWasetland lfo module and replacing it by a Nysthi LFO

Interesting - where was the bpm LFO going to please? what was the path to MM?

and was this in the new 1.1.6 or previous version of Rack?

@steve it happens in 1.1.5 and 1.1.6, here is the buggy patch and the corrected patch, for you to test:

2019_11_03_FromStart__NOT_BUGGY_003X.vcv (96.5 KB) 2019_11_03_FromStart__BUGGY_003X.vcv (96.4 KB)

1 Like

great - thanks for those - will check it out!

Right yes - that one is odd. For me the crash happens on opening without even having to start the zzc clock. in fact if I unplug the LFO completely and restart I think the LFO is still crashed.

Also if I put a new instance of the LFO in the patch, use the same settings, and connect it to Trummor (without it having a clock input) the new instance immediately crashes.

I then found out if you adjust the skew knob on the LFO away from full left it seems to fix the issue? When I do that the jacks are no longer yellowed out and things start playing again.

2 Likes

Just to add what looks like a sends/returns bug is not necessarily that. With the Rack random bug which affected noise modules etc mentioned earlier - it looked like a send/return bug on the mixer in that all the aux jacks got yellowed out and one of the Aux channel VUs on MixMaster would max out - but it had nothing to do with the Aux, it was the noise module outputting infinity that caused the crash in the mixer and the part of the mixer that crashed was either the filter or the track VU - nothing to do with Aux. In fact the crash still happened even with the AuxSpander removed altogether. Point being looking at the yellowed out jacks and for a module outputting constant voltage can be a bit of a red herring…

4 Likes

The cable end is lit up brightly. There is also a click when the cable is plugged or unplugged.

I just reloaded that same patch, and the mixer is working normally now. If I see it happen again, I will endeavor to capture more useful info.

1 Like

I’ve never had the problem with sends or with Plateau, but I have had it with NYSHI 4DB after the mixer - no sound and it would just be maxed out. So I just removed the module and haven’t experienced it since.

It happened again. Scope shows that both the left and right main outputs were at a steady 10 volts DC.

that’s… weird. Mixmaster main out to 4DCB, to… Audio-[8|16]?

Do you have an Audible Resonator in your patch by any chance?