Got a strange problem triggering Entrian Drummer patterns with Entrian Timeline

I can’t figure out what’s happening here, the pattern changes are fine until it gets to the 8th bar where it is an empty pattern, then when it is supposed to return to one of the previous patterns the first beat or two is being skipped or not played. I also noticed that the first kick is played at the start of the blank pattern, it’s like it is playing a beat behind.

Just wanted to get some opinions before reporting this because it’s most likely I’m missing something very obvious. stringyfugue_simple.vcv (73.4 KB)

I just played around with it, tried it without swing, added a note in the ‘empty’ bar immediately before the beat comes back and it still had the same issue where the first beat gets missed. Looks like a bug to me too.

1 Like

Yeah, it is strange. First I thought that the delay introduced by the timeline is the problem. I recorded the clock signal to another timeline-track and used that to clock the drummer. Don’t work. Then I set all your probabilities to 100%, I thought maybe he is calculating that for the next note right after the trigger of the last, nope. Then I introduced a big delay on the clock and that finally worked. So I think there is a big lag when switching presets.

1 Like

@TroubledMind: Thanks for the bug report and the patch - it’s most odd. I’ll look into it and get back to you once I’ve figured out what’s going on.

3 Likes

I get the same issue with Entrian Timeline so it must be a bug , Entrian Melody works so sequence your drum patterns with it in the meanwhile … that’s what I do.

This was a combination of a bug and a gotcha.

A new build is on its way to the VCV Library that fixes the bug and makes dealing with the gotcha much simpler.

The gotcha is the fact that Rack cables come with a one-sample delay, so if you feed the same clock to both a scene sequencer and a trigger sequencer, the change of scene will arrive one sample too late to affect the first beat of a scene.

The fix is to add a one-sample delay to the trigger sequencer’s clock, and this update makes that easy: there’s now a “Delay Clock” menu, which lets you control the clock delay without needing to use a separate delay module. And what’s more, that menu has an “Auto” option, enabled by default, which makes the most common cases (including @TroubledMind’s example) just work without needing to do anything.

image

The bug, as @mosphaere found, was that the clock needed to be delayed by lots of samples, not just one, in order to make things work. Now fixed, but less relevant since the clock delay is now built-in and in most cases automatic.

5 Likes

If I may suggest some improvements it would be useful if there will be a loop reset button , for resetting the loop in sync with the clock to help work on longer sections and in conjunction with other sequencers in the patch.

How about an option for the Reset button and input, that would move the playhead to the start marker rather than to the start of the song? Would that give you what you need?

1 Like

That’s great Richie, thanks for looking into it and providing a fix! I did wonder if it had something to do with the cable delay, well done for thinking of a clever solution!

1 Like

yea that would be awsome because right now I often need to reset the whole sequence for it to sync with a bunch of other sequencer , set the loop markers and let it go to the end once for it to restart the loop in sync.