Forcing Rack to dedicated gpu

Hi there, I got a new laptop with an extra gpu ( NVIDIA Geforce rtx 2070). I assigned it in the NVIDIA control panel to Rack.Now I see in the Tasmanager that Rack still uses the internal GPU mostly.When I deactivate the internal GPU I can’t start Rack ( could not open GLFW window…). I have the newest Drivers installed. Is there a way to force Rack to only use the NVIDIA gpu? Thanks in advance for advice!

I don’t have a laptop with an nvidia card, but is there something in the Windows power management where you could disable the nvidia card from sleeping when not under load?

On Windows 10:

  1. Press the Windows key, type “Graphics Settings”, enter.
  2. Click Browse and select your Rack.exe (Possibly C:\Program Files\VCV\Rack\Rack.exe).
  3. Click Options and select “High Performance”.

By default I think it was set to “Let Windows decide” for me and it was running on the integrated GPU.

2 Likes

@rare.breeds you made my day! 10% less cpu-load! Thanks a lot!

2 Likes

This seems like a candidate for something that should be listed in the manual, @Vortico

2 Likes