Error on launch "Rack's resource directory "n_.../res" does not exist" on Mac

Make sure Rack is in the Applications folder and you are launching the app by double clicking on it.

Zoom is also Command + (zoom in) and Command - (zoom out) on mac

2 Likes

i had same problem when first opening vcv rack on a macbook but the problem was solved after connecting to internet and re-opening vcv rack good luck TM

1 Like

Thanks for all the help folks. Zoom issue solved, and modules updated inside rack, so that’s all nice. Much appreciated.

Good to hear, @lukehuels! Did you find out the reason, and/or could you please share more details about you fixed this? Did @tonymono’s suggestion make the trick?

1 Like

For anyone else reading this, I get this if I double click on patch.vcv file expecting Rack to just open and load the patch (which works fine for other types of file and their respective applications).

Instead, make sure Rack is in the applications folder, double click on the Rack app to launch it, then use Rack’s menu to find and open the patch.

1 Like

Hello there! I have the same problem wirh Rack installation!:frowning: My computer is a 2009 MacPro with os 10.7.5. I downloaded the Rack zip folder from the website, than I copied it into the application folder and than I extracted the file. When I try to start the program (by clicking on the Rack file just extracted) it says: ‘Rack’s resource directory “n_0_290887/res” does not exist. Make sure Rack is correctly installed and launched.’ What can we do? Thank you very much :heart:! Best regards. Giuseppe

1 Like

Hello everyone

I followed the simple instructions for the masOS installation (Download zip file, drop content in the App folder) but when i try to launch the app i get the following error message: ‘Rack’s resource directory “n_0_213044/res” does not exist’, with the number changing everytime i try to launch.

I’m using macOS 10.8.5, and i’ve successfully used VCV Rack v 0.6.2c in this computer before, launching the app directly from the downloaded disk image, without dropping it in the app folder.

Any clue in what might be causing this issue and how to solve it?

Thanks in advance

Had the same issue. Starting Rack from Applications/ solved the problem for me. (Occasionally the error returns when trying to start Rack from the recent started Apps in the Docking Bar.)

1 Like

Same issue and same (partial) solution for me. I will just add that replacing the icon in the Docking Bar seems to have fixed the problem with starting from the Docking Bar. However, launching Rack with a vcv file brings up the error still.

1 Like

Thanks - this worked. Moved VCV app into Applications folder then into Dock.

I experienced the same issue on Mac OS 10.8 and the above mentioned tips did not help. But I managed the get it to work by right clicking on the app and selecting "Show Package Contents and open it by double clicking /Applications/Rack.app/Contents/MacOS/Rack

1 Like

I have this problem: Last login: Tue Mar 24 09:25:48 on console

/Applications/Rack.app/Contents/MacOS/Rack ; exit;

mkdir: /Users/alviselupo/.bash_sessions: Permission denied

touch: /Users/alviselupo/.bash_sessions/A4DCB0DE-DD11-44D4-BE0C-4EFD83CEAA5F.historynew: No such file or directory

macbook-pro-di-alvise-lupo:~ alviselupo$ /Applications/Rack.app/Contents/MacOS/Rack ; exit;

Could not open log at /Users/alviselupo/Documents/Rack/log.txt

Thank you! That did it!

Hello, I tried in both ways: opening from the package content, and thru the app folder. but doesnt work. The system tells me “its damaged. move to trash”. how can i fix it? im on mojave 10.14.6

Just bumping- This is happening for me in Mojave as well, except in my world I can open Rack in Terminal by clicking on /Applications/Rack.app/Contents/MacOS/Rack.

Copying and pasting the Rack App to applications, or the dock does not allow me to open it.

Newbie here. I got the following screenshot and although I can use VCV Rack in Mac OS Catalina…I cannot view other files downloads?

Dear all,

I have trouble opening the VCV Rack 1.1.3 version on my Mac OSX 10.10.3. During the last week I have read the previous threads and posts about people having trouble opening the program. Following previous advice was to no avail. The task manager shows the program as running, but nothing is showing up.

I would appreciate your help.

Kind regards, Robert

Delete and reinstall V 1.1.6 :slightly_smiling_face:

3 Likes

It’s possible that some Modules have updated and require things that were not in Version 1.1.3. I also think dowloading version 1.1.6 should resolve the problem,

Let us know if it’s not the case :slight_smile:

1 Like