Developing on M2 Mac; ARM64 plugins not loading

Edit: I cleaned up a lot of things on my Mac and it is finally working… Thanks for all the support guys.

Hello. It’s my first time programming in years, so please excuse me for the novice question. I am currently on an M2 mac, and have followed the basic tutorial for creating the MyPlugin plugin. However, when I load up VCV, nothing shows up.

I tried going through my log.txt and noticed that there was no mention of arm64 anywhere, including anything about errors. There are only mentions of plugins in the “plugins-mac-x64” folder, while my plugins are being built to the “plugins-mac-arm64” folder.

I’m assuming that VCV is only loading plugins from the x64 folder, and I have to configure that?


  • My installed SDK and VCVrack software are both the same versions (latest ARM64)
  • Building a plugin works on my windows computer, so I definitely didn’t miss any steps
  • Yes, I tried reinstalling VCVrack, restarting my mac, etc

I think it’s make install, or something like that?

First of all, thank you very much for the Formants filter.

Second, I did run make install, and the plugin was built into plugins-mac-arm64 folder. No luck, however

1 Like

Not a programmer but what rack version are you running ARM64 or X64 ?

Oh,ok. Fwiw, I make plugins the old fashioned way. I build rack itself, then build the plugins underneath.

ARM64, of course

1 Like

Something useful in the log.txt ?

I think when the helper script prompts you, you get:

Version [1.0.0]: ?

1.0.0 is a bad choice - a plugin must match the Rack major version it’s compiled to run with. version should be at least 2.0.0 for rack 2.4.1+

Perhaps this is what is wrong - too low a version number in plugin.json

I sent an email asking VCV to reference this:

“Note: The “major” version number (e.g. the 2 in v2.3.4) must match the major version number of Rack. See ABI/API Version.”

That happened with my windows build and I was able to fix it by doing so. I tried the same for my mac but to no avail… I think I remember why I quit my programming journey haha

Like @Yeager said, above, the VCV log file will most likely have something interesting in it.

1 Like

Read it like a book, nothing. I tried contacting VCV support, hope I will get something out of that

There can’t be nothing. Does it mention you plugin? If not, that means it’s not there.

It is now😊 thanks for the support, wish me luck!

good luck!

1 Like