hi there,

here is a new plugin dbRackSequencer i worked on. Most of the sequencers in this plugin are re-implementations of sequencers of the XOR plugin or inspired by them. The short story is: As i got finally the XOR plugin running in V2 and dived deeper into the modules i found out that a port does not make much sense for me. E.g In the V1 XOR plugin there was no use of polyphony and i found a lot of missing features which i liked to have.

The pre-release can be found here:

The manual is here:

tests/comments/ideas are welcome.


Wow! Absolutely amazing!

What a great weekend I’ll have! :star_struck:

I will test them asap

This is wonderful.

Thank you 1000 times. They look wonderful.

Holy cow batman, that’s a momentous amount of work you just dumped on us there doc, awesome and thank you! Well done on taking on the XOR and bringing it forward, and we now have a Klee again, wohooo. Fantastic with the videos on the README page as well, some of those modules look mighty interesting and capable. Definately some tutorials will be welcome with these ones, they’re not beginner modules :slight_smile: I smell some Orca inspiration there as well which is awesome. They load fine here on my ancient Mac and the CPU consumption seems very lean, great! My only initial gripe would be that the text is a tad on the small side. Really look forward to playing with these…

Well done!!

Built without issue on a Mac Mini M1 (x86_64). Looking forward to testing today, I loved those XOR sequencers. Thanks a bunch ! :slight_smile:

I tested some modules: Uno, M851, P4

they work great and no crashes or other problems yet.
Here on Win11 with VCV 2.1.0

This is awesome, thank you so much. I feel like The XOR collection not being ported was a huge loss, the sequencers were amazing, and there was even big update which added new modules and quantizers in all the sequencers. I’m so happy to see some of them back in some form, I missed the klee!

1 Like

Thanks to all for testing and your comments are very motivating to bring the plugin forward. Here is a new Pre Release:


Doc: Enhancements and added Klee video

Fixes and enhancements: ACC now has a trig output which fires when the state goes through zero. ACC now has a manual reset button

Klee: Menu option “Instant” which causes the CV output to be computed permanently (not only on clock signals) - costs about 0.7% CPU

C42: a click on the grid with the right mouse sets the CvX, CvY params. The position of the params is visible now in the grid.

The Matrix: fixed crash on windows if a polyphonic cable is connected to the CvX input after loading the module.


Great work, doc, you are my new hero VCV-dev now :sunglasses: Just tested about a third of your new modules and already very impressed.

is the amazing Nag-Nag-Nag somewhere on the list of future ports?

Cannot say, because i only port modules which i fully understand and like to use in my own musical context which is not the case for nag-nag-nag yet. First i would have to dive in and make something with it. I will check. (This is also the case for all other modules which are not ported).


understood, that is just one of those out of the park thinking sequencers that was great fun…

here is an old v1 patch using it, needs some love sound and mixing wise for sure, but was made a long while back…

FG_01_94_11_NagNagNag_Fun.vcv (79.8 KB)

Here we go. See manual.


Manual I already saw. Nicely done indeed! Weekend will be playtime…

Hello, thanks for the great implementation of the sequencers. I have a question about the Klee sequencer. Why are there no “Merge” switches for the busses in your implementation, contrary to the original and also the TheXOR implementation of the Klee sequencer? Or have I overseen something?

Ah, long time ago i have done this: The gate output should behave as if merge is on and the Clk as if merge is off. Please test!

1 Like

Ahh, ok. I will test this, thank you.


Thanks for this nice plugin!

A first question: how do I use the BPM input on the PwmClock? What is the expected input?

I tried CV and clocks but PwmClock didn’t react w/ a changed clock output.

Any hints?