DAW Start/Stop vs. VCV plugin

I have a recurring problem when I setup sequencers in VCV and run them as MIDI Effects or Instruments in Logic Pro.

I’ve setup my MIDI-CV and Clocked modules as recommended in previous threads (e.g., how to sync transport of Ableton and Impromptu Clocked? ). I’ve tried both MIDI-CV’s STRT and CONT triggers (based on that thread). On the other hand, @steve suggests on that thread, that it’s not actually necessary to use the MIDI-CV STRT/STOP/CONT triggers at all when running in a DAW.

The two problems I’d like to “fix” are:

  1. Often, when I “stop” the Logic transport, Clocked stops with one of its CLK output gates held high. This can result in an envelope held open (and an annoying never ending note ringing). The only fix I’ve found is to repeatedly start/stop the DAW transport over and over until the stop causes Clocked to stop with all gates at 0V.
  2. I often want to export a short sample of a piece (2 or 3 measures). I do with with Logic’s File->Share->Song to Music and have it export only the cycle area. With a VCV sequencer, this doesn’t work - the VCV instrument continues to run even after the end-of-cycle and I end up with an extra minute or two of audio in the exported sample. The only workaround I’ve found stop the VCV track from playing past the cycle is to draw in some Volume automation on the track (or Master output) to bring the volume to zero.

This seems like something I’m doing wrong / failing to map STRT/STOP/CONT triggers into VCV, failing to select the on-stop/on-start behavior in Clocked – but I’ve run out of ideas. How are the rest of you patching VCV when running in a DAW? (I suppose this may be Logic specific, but I would guess it applies to any DAW?)

Uncheck “Outputs high on reset when not running” Check “do internal reset/Send reset pulse” on both On Start and On Stop.

And maybe experiment a little with the settings.


:+1: The Do Internal Reset does seem to solve (at least in my last few minutes of testing :)) the “gate stays high” problem.

It does not help with the “sequencer continues to run after cycle end” when bouncing to audio. For that, I suppose the DAW is sending a different message (or not sending one at all?) that isn’t getting picked up by Clocked?

I don’t know I only have the stand alone version of VCV, but that sounds right.