Dangerous : random full scale distorted digital noise in modules


New VCV OSX user here, and a very happy and inspired one!

I’m not a developer but I have come across a very dangerous bug in VCV for OSX. Dangerous for the ears, that is.

It happened in both mscHack PingPong (numerous times in one day) and Blamsoft XFX Reverb (once so far). Both were in a chain that ends with NYSTHI autofader, that has two RJModules Buttons (fade in and out) connected to it.

When I fire the fade in button, I get extremely loud (full scale) distorted digital noise on my output. Resetting the module (pingpong or XFX Reverb) stops the noise again, luckily.

Hopefully this can be tracked down for improvement. If I can be of any more help, please let me know.



Hi Marcel

As a general thing, to prevent damage from audio spikes, try and put one of the limiters (e.g. the Bogaudio LMTR module) just before the Audio module. But yes, it is possible that some modules in Rack have bad audio spikes. If you’re convinced that it shouldn’t be possible, I would encourage you to submit bug reports to the plugins in question, usually on Github.

Have fun with VCV Rack!

1 Like

Hi Lars,

Thanks for your reply. Some spikes would be okay with me, since we’re using open source v1 software. But the noise is more than spikes, unfortunately. It’s non stop full scale mayhem.

I will look into creating bug reports through GitHub, thanks for pointing it out to me.


this is one of my favorites. do NOT hook something like this up to audio.

1 Like

If you own VCV Host FX, I’d highly recommend checking out Ice9 from Cerebus Audio (still available for free via Plugin Boutique). It’ll automatically mute your output whenever the audio crosses a user defined threshold. Put this right before your audio outputs in VCV Rack and you’ll never have to worry about sudden jumps in volume blowing out your ears.

In fact, if any developers are looking for a great module idea, a VCV module that does the same thing of Ice9 (without needing to run Host FX) would be terrific!


I click on this thread because I wanted to hear the “random full scale distorted digital noise” but sadly there’s not audio here :frowning:


this is why you should always put a limiter on the output. i also use bogaudio’s lmtr for this. and in reaper (my daw) i use the free loudmax vst.

1 Like

@modlfo I will be sure to capture it next time it happens.

1 Like

if you use one of my nysthi::mix you’ll get the soft or hard limiters (context menu)

What are your settings for lmtr? I never really done this.

threshold -3dB, output gain 0, hard knee

see for example my patches for musical pals #4

1 Like