Crash with no log message

Yes, I’ve sent an e-mail to support.

I have a repeatable crash where I’m editing the channel name in MindMeld MixMaster. I click in it and backspace delete the existing label. Then when I type the first character – in this case ‘G’ it crashes.

Has anyone else seen something like this?

I’ve tried it just now but can’t reproduce it, that’s quite weird that you would get a crash doing this. What platform are you on?

@steve I wonder if this is the issue where you guys compiled a special version of the MindMeld plugin for 2.3.0.

I tried to download that special build but the link in the community post is 404 not found right now.

No that was related to a very specific issue in PatchMaster. The change we made in that special build is now integrated into the main MM plugin in the library.

1 Like

Just to add that I can’t reproduce this crash either (I’m on Mac)

What is your host?

Sorry. Windows 11, Core I7, 32GBytes RAM, Focusrite 18i8.

VCV free vesion?

I was able to get a crash without the MindMeld modules present in the patch, so I think the bug may be elsewhere. When I have no audio device present, I can get a crash, but when I remove the two Confusing Simpler modules and continue playing with the patch, it doesn’t crash. This may not even be an indication that the Nysthi modules are the culprits, but I suspect a memory leak somewhere, and those have a bad habit of corrupting the behavior of other modules and making it appear as if those other modules are the source of the crash (I have seen this before in Rack). But just for completness sake, can you try to reproduce your crash without the Nysthi modules in the patch?


Memory leak don’t crash

it come with time

I think its a problem of non logic use

I own Rack Pro, but I’m using standalone mostly, which if I recall correctly, is the same in the Free and Pro versions.

1 Like

I know that there are some things that will crash in Nysthi. If that’s the problem I’ll just live with it, because when Nysthi stuff works it’s fantastic.

@synthi has indicated that he makes the Nysthi modules for himself, and is glad when people use them. But he supports users when he’s got time, and he’s busy with other stuff right now.

1 Like

Some plugins seem more prone to crashing due to other plugins’ use of uninitialized variables or out of bound array indexing. Several times when chasing such a problem last year, I thought for sure that certain plugins were the source of the crashes, and they may have been, but only as a secondary problem due to another plugin corrupting the memory space. These are extremely difficult to sort out. Of course in my case, the log file often implicated those secondary modules more often than implicating the true problem module.

1 Like

What I’m concerned about most is ‘poof’ crashes that happen when I’m not interacting with modules.

Crashes I’ve had recently:

  1. Shift-Ctrl-D (duplicate with wires) on theoretically solid modules (like Bernoulli Gate)
  2. Typing into text fields.
  3. Sometimes when trying #1, the crash comes when I’ve pressed ‘Control’ and ‘Shift’ but before I press ‘D’.

I just retired from being a programmer (after 40 years) and I don’t want to be the one who has to build & link with Address Sanitizer to figure these things out. I have a suspicion, not based in any actual knowlege, that there may be issues in the core Rack code that is interacting poorly with nominally correct plugins like Mindmeld.

What you say makes perfect sense. All I am saying is that the problems I was having last year sound essentially identical to what you are experiencing. In my case, after a lot of help from others, the crashes were traced to a very highly respected plugin and was verified and corrected by the developer very quickly and I have had no such crashes since. This issue was one of array indexing with an invalid index (negative index) I believe.

A couple of experienced developers tried address sanitizer and debugging and could not determine the problem although they could reproduce the problem using my patch.

This problem would quite often crash while I was doing random things in the patch and sometimes implicated other modules. Occasionally the true problem module would show up in the log. As often as not, the log showed no crash.

I was very convinced at the time that Rack might be the source of the crash as often the log would show a crash occurring while in Rack functions code.

Yours could very well be something totally different.