Could not load plugin, Failed to load library code 1114?

I was merrily creating a new module for my plugin - everything was working and sounding great.

I made what I thought to be an inconsequential change to my source code, and BAM - no Venom plugin in my library :woozy_face: :thinking: :angry:

I get no errors or warnings when I build my plugin.

In my log.txt I get: [3.335 warn src/plugin.cpp:237 loadPlugin] Could not load plugin D:/Users/david/Documents/Rack2/plugins/Venom: Failed to load library D:/Users/david/Documents/Rack2/plugins/Venom/plugin.dll: code 1114

I tried backing out my latest changes to get back to what was working, but no luck (I hadn’t saved to my local git yet, argh…)

I can download my published version and everything is fine. But my new beta version simply will not load.

Any ideas what code 1114 means? Any suggestions on where to look for the problem?

What exactly did you change?

Can we view your souces?

Never mind, thanks.

I saved my code to a dev branch, switched to main branch and built, then switched back to dev branch and built, and now all is fine :interrobang:

Not a clue what happened.

But I will be pushing my dev code to github soon, as well as posting some binaries, looking for feedback on a new expander module.

maybe make clean helps here, becaues make only rebuilds a surce if the timestamp is newer than the built file. I recommend make clean when switching branches.

1 Like

Thanks. I forgot about that option. I wonder if clean might have worked on its own. It was actually the switching back and forth between branches that fixed the problem, whatever it was.

1 Like