Core dump on exit, weird valgrind result

I noticed that Rack (on Centos7, with the v1.1.1 release and a compiled version to get debug symbols) is dumping core on exit. So I ran it under valgrind.

Theres a ton of reports that look like they’re down in the GL libraries, but the crash comes here. This is again down inside a library, and my understanding of Rack internals is not such as to venture any guess as to what is going on:

==8155== Invalid free() / delete / delete[] / realloc()
==8155== at 0x4C2ACBD: free (vg_replace_malloc.c:530)
==8155== by 0x2BB52A9D: dsp_ctl_descructor (dsp-ctl.c:627)
==8155== by 0x400FFB9: _dl_fini (dl-fini.c:253)
==8155== by 0x8B87C28: __run_exit_handlers (exit.c:77)
==8155== by 0x8B87C76: exit (exit.c:99)
==8155== by 0x8B7049B: (below main) (libc-start.c:300)
==8155== Address 0x2b4b9090 is 768 bytes inside an unallocated block of size 3,328 in arena “client”

do you get the core also with an empty Rack? i also noticed core dumps on exit on my arm32 and arm64 builds but so far always attributed them to the less than perfect opengl hacks on arm. sometimes i only got core dumps with plugins and none with an empty Rack - but i never looked closer at them in a proper any more scientific way.

best wishes - hexdump

i just noticed, that i get a core dump on exit when the SkJack plugin is installed - if i remove this plugin i no longer get a core dump. i observed this back in 0.6.2c times already before. this is on linux ubuntu 18.04. can someone else maybe confirm this?

I get a core dump whether I use SkJack or not on Manjaro. Also, the wires from the mscHack mixer to SkJack are gone every time I start up, even though I added them to the default patch.

EDIT: after reading up through the posts above the one I responded to, I tried opening the patch back up, deleting eveything, and then shutting down, and it still dumped core.