Compiling plugins (first time)- need help!

I am trying to compile plugin from github for the first time. Spent the last night trying, googling and… nothing.
I use Windows 7 and MSYS64.
After running “make” this error appears:


make: jq: Command not found
make: jq: Command not found
c:\Rack-SDK/ *** SLUG could not be found in manifest. Stop.

I did do this:
pacman -S mingw-w64-x86_64-jq

And did not help :frowning:
I have Rack-SDK downloaded, environment variable set.
Any suggestions please what to do?!

Hello, did you setup your build environment following the instructions in the manual?

yes, I did these:

pacman -Syu

pacman -Su git wget make tar unzip zip mingw-w64-x86_64-gcc mingw-w64-x86_64-gdb mingw-w64-x86_64-cmake autoconf automake mingw-w64-x86_64-libtool mingw-w64-x86_64-jq python

Which plugin are you trying to build? Is your current directory the root of the plugin when running make?

I tried 3 different (result is the same) -
I go to the directory (like ~/Fundamental) and there run “make”

I think there is something wrong with your environment variable RACK_DIR. Can you move the source folder to C:\Rack-SDK\plugins\pluginName?

Is the plugin.json in the directory you are building from? I had the same error when that file was missing. Perhaps you are not building from the correct branch?

plugin.json is present in all three directories, where I run make from

I’ve just built these so can you try?

1 Like

I have moved (copied) plugins to Rack-SDK
and run make here:


michal@MM MSYS /c/Rack-sdk/plugins/CharredDesert
still the same

tried, and still missing SLUG

It’s important to start MSYS2 MinGW 64-bit. I get the same error when using a different environment.

1 Like

now! it is doing something !!!
thank you!

You’re welcome, I’m glad I could help :+1:

I just noticed you’re on windows and I have never built anything on there. On linux you don’t need to move the plugins inside the Rack-SDK folder and I’d be surprised if that is not causing the problem. With the variable means you can build it from anywhere, I’d try cleaning the Rack-SDK folder, cloning the repos somewhere else and try again.

As I said, I don’t know building on windows but it seems odd to me to try to build from a folder that is inside in the variables set for the build.

I’m confused though, you said you use Windows 7 but ran pacman, is pacman available on windows now?

Yes, if using MSYS2.

Oh that’s cool.

ok, now “make” seems to work fine, but “make dist” has a lot of “undefined reference to rack" or "undefined reference tonvgRGB’” and it all ends with “collect2.exe: error: ld returned 1 exit status
make: *** [c:\Rack-SDK/ plugin.dll] Error 1”
and no dll file (is it what I should get after this process? :slight_smile: )

I am now trying to compile “Strums_Mental_VCV_Modules” and get some Errors
“undefined reference to `rack::app::ModuleWidget::fromJson(json_t*)’
collect2.exe: error: ld returned 1 exit status
make: *** [c:\Rack-SDK/ plugin.dll] Error 1”

should I have the whole Rack source somewhere ?

make dist creates a zip-file for distribution, but this is not necessary. Is there a plugin.dll in the folder of the plugin after running make?