Clock rate drops when connecting external sound card

Yesterday I was playing around with VCV and connecting it to my 2600 which I recently finished some repairs and mods on. The idea was to send sequencer data (I was using Foundry and clocked with Clocked) thru CV-Midi and out the CV ports on my Beatstep Pro. Worked great!

So I figured lets bring the audio in from the 2600, process it a bit and send it back out to my M-Audio Profire 2626 - which has been working fine for a long time. I installed the Audio-8 module, selected ASIO and as soon as I selected the M-Audio firewire device, the clock seemed to cut to almost half speed. The numbers still showed 120 but you could see the sequence step indicators slow significantly. I select ‘None’ for the audio device and the speed immediately returned to normal. I tried Sequence-3 and JW Simple clock - same behavior.

So thinking it might be OS or soundcard related (this machine is windows 8.1/64) I went to my other machine - which is a Windows 7/64 system with an M-audio FW1814. The same sort of behavior happened again.

Running the latest VCV Rack 1.1.6 Audio rate is 44.1khz Tried adjusting thread count from 4 to 1 - no change. Tried changing frame rate - again no change.

Any ideas as to what else might cause this?


Hi. This is normal behavior in Rack v1. Only if an audio driver and a device is selected Rack runs on proper timing. So, Rack runs actually to fast if no device is selected and at the correct speed if selected. Hope this helps.

Alrighty then. If that’s the way it’s supposed to work, great! I was a bit concerned seeing the drop in rate…it looks to be ~ 60bpm, not 120, when connected. That’s ok though.

Thanks for the response!


In Rack v2, the engine will not advance at all when a “primary module” is not in your rack (e.g. VCV Audio, VCV Recorder). The rack will be suspended in time.