Clock not keeping everything in time.

here is my patch so far, i have everything wired up to one clock yet when i click run my digital sequencer seems to be one behind and it never seems to all start at the same behind, I am very new to vcv rack, i tried right clicking and going through those options but i’m not sure it helped, any suggestions would be greatly appreciated

i would send the patch but because i am a new user i dont think i can

Make sure that “outputs high on reset when…” is turned off and maybe set on start to set reset pulse and on stop as shown here :

1 Like

Fairly certain it was the outputs high, you’ve sorted me out twice now thank you so much :slight_smile: