Cant get toolbar to appear on my Dell XPS 15

Hi there,

New to the forum. I just installed VCV rack on my Dell XPS 15 (4k) i7 NVIDIA GT1050) and the toolbar will not appear. Have tried all the different screen resolutions to no avail. HELP…anyone please…dying to use VCV Rack.



which OS do you use? on win try scaling the screen in the OS settings.

f11 will go to fullscreen, might be worth a shot!

Thanks for the suggestions guys but it hasn’t done a thing. I tried numerous scalings on Windows 10 (my current OS) to no avail just had to restart my computer a bunch of times to get the settings back to normal. I think it is a problem specific to Del XPS 15 4k infinity screens perhaps. I found this old Github thread from 2017 and never saw a fix

I really don’t know if its fixable???

All drivers up to date? Particularly display driver and OpenGL. If there is an update available I would probably try clean install that update from NVidia.

1 Like

I have a Dell XPS 15 9560 laptop (4k screen, Nvidia GTX 1050) and it runs VCV flawlessly. I’m also thinking this has to be a drivers issue.

Same for me, no problems at all.

@smchapman71 Have you compiled yourself? I don’t think so because you wrote “installed”. Do you use some alternative Shell, something like “Classic Shell” or similar stuff to change the behaviour of the Windows UI or windows? Like @Coirt already asked, do you use the Nvidia driver that comes with Windows 10 or do you use the official driver from the Nvidia webpage? I use the driver which comes with Windows 10, which do you use @bp.dtmr?

Thanks for your help but again it did not fix the problem. I have updated both intel and NVIDIA drivers (Nvidia wasn’t current). Now updated to latest drivers but still not displaying the toolbar. Ready to tear out what hair I have left :frowning:

Can you post a screenshot?

sure no problem Ben. Have posted below. Cheers

Interesting. Are you using any kind of window manager software or is something preinstalled by Dell? I can get the window looking the same way if I maximize Rack and then „drag detach“ from fullscreen using the title bar. After I release the mouse button the taskbar appears again.

Not that I can find installed. Drag and release doesn’t work either. Thanks though. All suggestions appreciated.

From experience Windows would sometimes look like this due to some sort of customization with fonts, colours and themes etc. On close examination of the image the toolbar is there. I shan’t be surprised that the buttons are there but with the font being the same colour as the toolbar so invisible.Try clicking along from left to right just under the window title please.