Can't connect behind corporate proxy

I’m trying to connect to the library behind a corporate firewall with a proxy. Every time I do it just times out, meaning I can’t load any plugins.

I tried adding the proxy address to settings.json but it didn’t work.

Perhaps it is not white-listed on the Corporations servers.

There is no proxy property supported in settings.json.

I haven’t tested this, but you might be able to pass environment variables to libcurl. https://curl.haxx.se/libcurl/c/libcurl-env.html

Does the Windows version use curl? I should have mentioned I’m on Windows 10.

My workaround was to install VCV on my home machine, download all the modules at home and then copy my Rack folder across. Means I have to do manual updates, but at least I can use VCV at work.

Has your employer got any jobs going? :wink:

Yeah mine once they realise how much time VCV is eating up!

1 Like

Yes.

I tried setting environment variables http_proxy and https_proxy and setting them to the right address, and I also tried adding the same information to a .curlrc file. But nothing, even after a restart.

It looks there’s a change committed to make curl have proxy support:

Did this problem get resolved? I’m not having any luck, with ~/.curlrc reading:

ALL_PROXY = www-proxy:80

Is it possible now or not? And if it’s possible where do I have to set the proxy IP and port?

libcurl and therefore Rack doesn’t read .curlrc. It uses environment variables such as http_proxy and all_proxy.

I think so, in Rack v1.1.6.

Got the same problem. A 10$ wifi usb-dongle solved it. Got unrestricted access once hooked the dongle to a mobile hotspot created by my phone. I have to unplug the network cable to do it, but that’s a minor nuisance.