ByteBeatMachine: Crash in Rack v1+

hi there, I’ve just updated some plugins and downloaded some new ones. After that VCV started crashing when I right click to load modules. I downloaded the new ones, Prism, Ahornberg and ByteBeatMachine and traced that ByteBeatMachine was the culprit.
Just a note to the creator of this module.

MBP OS 10.8.5

best

1 Like

It works fine for me on Windows 10.
I don’t know Mac, but I think you try to reinstall VCV Rack (1.1.1).
Cheers

confirmed crash w/ mac mojave 10.14.5

Had a crash also when I searched “B”

The issue tracker on git hub is the place to report there is already a report opened.

1 Like

Also confirmed crash on my Mac here, wrote on the github issue. It’s definately loading the preview of bytebeatmachine in the module browser that causes it.

Hello, I currently develop the plugin on windows. I can also test it on linux, but unfortunately I don’t have a mac so it is not possible to test on mac. Occasionally I get crashes on windows too. Maybe it has something to do with the duktape engine. In any case I would appreciate feedback and logs so that I can iron out the bugs.

CrashLog.txt (56.3 KB)

hope this help :slight_smile:

I posted a Mac crash log. Hope it helps.

Hi @bokontep. Further to this. I just cloned the repo from https://github.com/bokontep/BokontepByteBeatMachine and built it using the Rack SDK v1.1.1. It built OK and is working on my Mac (on Mojave v10.14.5 with Rack v1.1.1). The module shows up in the browser module OK and loads fine. See the attached screen shots. Do you want me to share the Mac distribution zip with you?

Here also … MacOSX 10.13.6

Deleting the folder /Users/<your_username>/Documents/Rack/plugins-v1/ByteBeatMachine solves the problem until there’s a new MacOS compatible version.

EDIT: Unfortunately it reapears in the Library menu to update again, SOOOO … this means that until this problem is solved, Mac users would have to go again and delete the above folder evey time we update modules. … See the @immortaljellyfish post below for the right solution until the problem is solved.

1 Like

Hi @Josep. Deselecting the 1.0.0 version of the plugin via the VCV Rack Plugin Library (that is, clicking the red “-Free” button to make it show as a blue “+Free” button) should stop it being downloaded to your library again. When the bug is fixed you can add it again. :slight_smile:

2 Likes

Yep, thanks for the tip @immortaljellyfish … I always thought that once the “Free” button is turned read it could not be reversed … So a learned sometething new today, thanks.

VCV Rack world is awsome! :crazy_face:

I was reading the VCV Rack changelog after following a link to it from another post, and there are two changes for the v1.0.0 that says this:

  • Allow user to see changelogs of plugins before updating their plugin library.
  • Allow user to update individual plugins.

I’m not at home to check this now, but i don’t remember have seen any of those options in the menus :thinking: … Do you know anything about it?

I can only half answer this one at the moment.

In Rack v1+ when you add a new module to your library, or a module you have already installed has an update, you can pick which one to install instead of just clicking “Update all” in Rack’s Library menu. Here’s a screen shot showing that…

02%20pm

As for the changelog, I’ll have to check the next time I have updates for modules waiting for me. :slight_smile: Edit: @richie has answered that one. See his answer below.

1 Like

Clicking the name of a plugin on the Library menu, rather than clicking “Update all”, will update just that plugin. In the screenshot, I’ve just clicked on Bogaudio and it updated, replacing the version numbers with a tick (1):

image

The link to the ChangeLog, if there’s one available, appears as a submenu (2).

1 Like

I just love the ByteBeat! :smiley:

bytebeat-v1.vcv (7.3 KB)