Building Rack on Arch Linux

Don’t want to waste Andrew’s time so I am wondering if anyone else has built Rack on Arch Linux. Need to get this working since my dist builds work ok on Windows, but not official VCV builds, and VCV cross builds on Arch Linux.

I am getting the error “RandR header” not found which appears to have been quite common with Ubuntu builds, but since the package manager for Arch is totally different, not sure what dependencies I need

So far I have always been able to get my ubuntu working by googling the error and then following the advice for apt-get. Once this didn’t work for me and I had to throw out my ubuntu VM and start over.

Also I look at the required packages for Linux - usually they will install directly in Ubuntu also.

Btw, the vcv manual says you need libglu1-mesa-dev, and that what the google hits on your error say. Have you tried that?

I think you need a package named something like xrandr-dev.

yes, but that’s usually pulled in by libglu1-mesa-dev, which is a listed dependency.

Doesn’t really make a difference which distro or package manager is used, the error is likely the result of the same problem so you just have to see which package solved their problem and find the same one in your repo. Ubuntu packages, particularly -dev ones like you probably need, are fairly granular and chances arch package is more or less the same.

yeah, the reason I am posting this here is that all of the google searches I did returned results for Ubuntu, which doesn’t do me much good. Not a complete noob :slight_smile:

also, ubuntu’s package manager seems a bit more granular, half the time I use pacman for something it doesn’t find it. I know this is because of my own ignorance, but again, that is why I’m reaching out to the community

Yse, I build and run Rack on Arch (it’s my main machine).

Try installing xorg-xrandr and libxrandr, both from the extra collection. Not sure which one could do the trick, but those are the only related packages I see on my system.

1 Like

pacman won’t search the AUR collection. There are some substitute package managers that do. I currently use yay as my package manager. It does a good job of downloading and compile AUR packages when needed.

I run Manjaro (Arch derived) and compile without issues. You might just need libxrandr.

In, I’ve assumed that you have X installed before attempting to build Rack or plugins using the Rack SDK. It’s good for the list of system build dependencies to be complete, so if you can find the exact Arch package you need (by uninstalling it and confirming it doesn’t work and reinstalling it and confirming it does), let me know and I’ll add it to the list.


I removed libxrandr and could not link the executable, so I think it’s safe to list that as a requirement.