build VCV Prototype on windows

Hello fellow rackers,

I’m trying to build the Prototype module on windows 10. I have successfully built the Fundamental and Bidoo modules without any problems. However, when I try to build Prototype, I get this when I “make dep”:

hidde@DESKTOP-SQV58NJ MINGW64 ~/rack/plugins/VCV-Prototype
$ make dep
cd dep && wget -c ""
--2020-02-26 07:35:11--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-02-26 07:35:11 ERROR 404: Not Found.

make: *** [Makefile:27: dep/lib/libefsw-static-release.a] Error 8

I did not forget to “pacman -S mingw-w64-x86_64-premake”, according to the github build instructions.

Any hints welcome,

Hi, looks like the project was moved to github so the download of sources fails - HTTP request sent, awaiting response... 404 Not Found. You need to change at least the URL.

Thanks, committed change. To update, git pull; git submodule update --init

1 Like

Many Thanks!

But it still won’t build :cry:

Everything works fine until supercollider, which ends with:

CMake Error at server/scsynth/CMakeLists.txt:26 (message):
  Portaudio selected as audio API, but development files not found

-- Configuring incomplete, errors occurred!
See also "C:/msys64/home/hidde/Rack/plugins/VCV-Prototype/dep/supercollider/build/CMakeFiles/CMakeOutput.log".
make: *** [Makefile:118: dep/supercollider/build/lang/libsclang.a] Error 1

I’ve searched around, but can’t find this error anywhere else…

Wait a minute!

I actually made this change myself, like this (from original code, line 27-34);

	cd dep && $(WGET) ""
	cd dep && $(SHA256) 9c6bb91f273fd7702bfdfc2f1f78b08e81f776d6d17b01d4542474103b564cda
	cd dep && $(UNZIP)
	cd dep/efsw-1.0.0 && premake4 gmake
	cd dep/efsw-1.0.0 && $(MAKE) -C make/* config=release efsw-static-lib
	mkdir -p dep/lib dep/include
	cd dep/efsw-1.0.0 && cp lib/libefsw-static-release.a $(DEP_PATH)/lib/
	cd dep/efsw-1.0.0 && cp -R include/efsw $(DEP_PATH)/include/

which works until the supercollider error.

Now, when I updated (make clean, git pull, git update) and make dep, I get this:

$ make dep
cd dep/efsw && premake4 gmake
/bin/sh: line 0: cd: dep/efsw: No such file or directory
make: *** [Makefile:27: dep/lib/libefsw-static-release.a] Error 1

Just thought I’d let you know.



Solving the supercollider/portaudio error just required “pacman -S mingw-w64-x86_64-portaudio”.

Haven’t tried to work with it yet, but at least it compiles fine,

Thanks again!

1 Like


So, apparently I was too fast in celebrating. “make dep” will build dependencies fine, but when I try to “make” the actual plugin, I get this:

cd dep && git clone "" --branch topic/vcv-prototype-support --depth 5
fatal: destination path 'supercollider' already exists and is not an empty directory.
make: *** [Makefile:113: dep/supercollider/build/lang/libsclang.a] Error 128

So, again, any hints welcome.

Also, sorry to bother you with noob quiestions, it would just be so nice to have Supercollider in Rack.

cd.. && make

Well, I’m running “make” from within the VCV-Prototype folder.

If I cd .. && make, I just get:

$ cd .. && make
make: *** No targets specified and no makefile found.  Stop.

since there is no makefile present

Then how is it going to make??

The makefile is in the VCV-Prototype folder.

First I “make dep”, which builds dependencies, then “make” to build the plugin.

The author of the SuperCollider backend hasn’t made a commit in a few months, so I’ve disabled the SuperCollider build. Whatever issue you’re having should no longer be relevant. Make sure your local repo is clean of your old edits and rebuild.

1 Like

Ok, sad to hear that. Actually, SuperCollider was the reason why I wanted to build Prototype myself - apart from learning the build procedure. I mean, Lua & Javascript is already available in the prebuilt version in the library.

Also, it seems, it’s not far from building with SuperCollider, since make dep is working. I will check the GNU make manual and continue to try here, if I come up with something that works, I’ll let you know.

I’m not sure why it was enabled actually. It wasn’t finished or ready for public testing.

Ok… but did you have it running?

If by “running” you mean if I’ve ever tested Brian’s SuperColliderEngine, then no.

Well, SuperColliderEngine within Protototype, in this case.

I will still see what I can do…

Is python still being worked on?

I’m the author of PythonEngine, and I always commit immediately after writing code, so you can look at the commit log to see when I last made a change to that file. Finishing it has a priority around #100.