Build Rack from source on mac m1

I am trying to build Rack from source as per the manual. All of the commands are run in an x86 shell. I installed the dependencies brew install git wget cmake autoconf automake libtool jq python with a separate x86 homebrew at location /usr/local/homebrew

When I run make dep, I encounter an error:

(sorry for the screenshot I don’t know a good way to paste the terminal output)

It looks like the problem is make is trying to build glew with c++, which on osx is clang, and the linker can’t find a library. I found this article, which suggested I set an environment variable LDFLAGS=-L/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib. The above command was run with this environment variable set. From the c++ command run by make it doesn’t look like this flag was added, and it wouldn’t matter if it did because /Library/.../usr/lib doesnt even have a file lstdc++

@johnschneider - maybe have a look at GitHub - lindenbergresearch/Rack.arm64: Virtual Eurorack DAW

I’ve looked at that page, but that deals with building arm libs/ executables. I am trying to build x86 Rack from an arm machine.

Dunno, looks at bit like native and x86 env. is mixed together maybe. Did you start that shell session with

arch -x86_64 /bin/bash

before running make?

I get the same error message running either arch -x86_64 /bin/bash or arch -x86_64 /bin/zsh before make.

I set up a second zsh profile to run all commands in an x86 environment, so running an x86 shell in an x86 shell makes no difference.

You probably need to set the osx architecture flag explicitly on the subordinate cmake. Namely set

https://cmake.org/cmake/help/latest/variable/CMAKE_OSX_ARCHITECTURES.html

In the cmake command line which probably involves adding it to the deps makefile. That will force cmake to choose compiler options

You may also need to set the deployment target sdk to knock you off 11.1

But these are pointers not answers. Hope it helps

So I’m pretty new to VCV, but I’m an old coder and pretty interested in seeing how much more efficient VCV can get when native - Is @heapdump 's github the current bleeding edge?

do you mean @hexdump ?

Ah - yeah @hexdump mentioned it above, but the Rack.arm64 github repo is Patrick Lindenberg’s, who I thought was @heapdump

Oh, yes, I think you are correct on both counts. I think Patrick posted a bunch of data on some other thread in the past. But it sounds like probably found all there is to find.

Yes Patrick’s build is the bleeding edge for M1 as far as has been shared on this forum.

There are a couple of pointers in this thread:
https://community.vcvrack.com/t/apple-silicon-m1-system-on-a-chip-to-rule-them-all/9569/301
Where you can read on which points the build got stuck.

Would really be great to see this take of further.

:slight_smile: