Blurry UI when used as a plugin... [SOLVED]

I just purchased VCV Rack 2 Pro and was shocked that the UI looks extremely blurry, when used as a VST-Plugin in Bitwig. I wish, I had known this before! A demo would have been nice… :frowning:

The standalone version looks extremly crisp on a 4k display, so I didn’t even think about it.

Is this a known issue, that’s still being worked on?

1 Like

No problems for me in Reaper, and Omri has done videos with VCV as VST in Bitwig and Ableton (and Reaper) where this wasn’t a problem. No other relevant hits when you search for “blurry” here. Suggest that you send a description of the problem with a screenshot to support, I assume the team is actively working on other VST issues. VCV - Support

Well, how could it even be possible, that it’s just blurry on my system? I also have Reaper installed and it’s all the same.

Maybe we have different definitions of what blurry means! :wink:

Would be nice if this was fixed in a future update. But not a showstopper at all…

I’m on Windows 11, BTW (UI-Scaling 175%). At a VCV zoom-level of about 168% it starts looking alright again… but it’s way to huge.

Is there a possibility that you’d provide a screenshot of the blurryness here?

may deselecting “stretch plugin window” in Bitwig and then reloading the VST would help …


Sounds like a high DPI monitor issue, so any posts “works for me” should be “works with a 4K monitor for me” if they are to be relevant.

Also, maybe it’s related to setting the UI scaling? I leave my 4K with default settings in windows.

That said, I haven’t experimented much with vst.

This fixes it for me on my main monitor that uses 125% scaling.

I had the same issue in Ableton. I had to disable ‘Auto Scale plugin window’ for the VCV VST. Follow this link with a description how to do this.

Artirua plugins look blurry - Ableton Forum

1 Like

Well, thanks for the help! :slight_smile:

I have set Windows scaling to 150%, which is the recommended setting for my display… I’ve also tried different scalings of the Bitwig UI as well as disabling the “Plugin-Scaling” and “Stretch” altogether.

In standalone-mode everything works as expected. I’ve attached a screenshot from the stand-alone UI and a photo of what I’m seeing in the Bitwig plugin-window, which is almost interlaced and not just blurry. ;(

And this is from stand-alone:

I really wonder what’s the problem here… it could be something system-specific, no doubt, but I’ve never had this issue before.

Now, that is strange! I’ve just reset the “Stretch Plugin-Window to Match DPI” in Bitwig to active and now it looks fine…

If only it stays like that! :slight_smile: Any ideas, what might be causing this?

Alright, I think the "Stretch Plugin-Window to Match DPI” is actually what caused the problem. When I deactivated it and then RESTARTED Bitwig. It looked fine!

I didn’t restart the application before, so Ahornberg’s solution worked!

Thanks so much!!! :grinning: