Behringer U-Phoria UMC204HD: Setup Help

Hello all,
Hopefully this is the right place to post.

So, after a lot of deliberation, I have bought a USB audio interface. I went for the Behringer U-Phoria UMC204HD, primarily because of the RCA playback outputs meaning I can run audio from my computer into my HiFi so I don’t need any specific computer only monitors. I’ve downloaded the drivers and set everything up and managed to get inputs and ouputs working on VCV rack via ASIO. Everything works well except from a few audio glitches. It would appear that running the audio from VCV out through the audio interface rather than the built in sound card/headphone jack causes more audio stutters and fuzz and beeps and whatnot. Almost like the computer is running a few too many modules (something I’ve done before!)
My question is, is this normal? Should an audio interface require more CPU to run audio through, limiting the amount of modules and whatnot I can load. My computer isn’t the best, but it should be able to load more than the core audio module, a mixer, plateau, and chronoblob right?
I’ve checked sample size and whatnot, and all the settings are the same. Another strange thing is that if I’m playing music off iTunes, but load up VCV rack in the background, muted in rack itself but with a medium sized project, the audio starts to stutter and “fuzz” anyway. Presumably this is linked in some way?

@PaulRidout I know you’ve mentioned before you’ve got a UMC204, do you have any similar problems. Is there anything obvious I’ve missed in the setup (likely!)

Thanks very much for any help, sorry for the text wall :upside_down_face:
Jim

Lower the sample rate? Raise the Block size?

Nice looking interface a lot of features for a great price!

I’m not too sure how performance is with Behringer stuff myself. Start off the lowest sample rate anyway but make sure it matches the engine sample rate and 256 block size maybe, seems do okay for me (2nd scarlet 2i4).

Having a dedicated interface can take some of the audio load off a cpu. Using a low buffer/high sample rate will increase cpu. A higher buffer will decrease cpu load as will a low sample rate. You would have to find a good balance. Just remember each time you change ASIO settings you might not necessarily see a difference until you restart Rack and or reboot. ASIO doesn’t take too kindly to having settings changed on the fly sometimes, from my experience anyway.

Make sure you have the correct/latest drivers and if it is a latest driver perhaps a previous driver gets better performance?

On the RCA outputs. You could look into getting a couple good quality 1/4" Jack to RCA adaptors or a TRS to RCA cable it would be on a balanced output, RCA does not have a Ground though so probably a waste of money if it is going to a Hi-Fi.

1 Like

I’m using a UMC404HD myself,
I’m on windows10 and have no problems, but I don’t use the ASIO driver from Behringer,
it is poorly coded.
I use DirectSound and I can’t go below 256 blocksize.
But with my settings it works pretty decent.

I would suggest you try some other driver not the ASIO first and see what happens.

1 Like

Will your device work with WASAPI? In my experience, the performance of WASAPI vs. ASIO on Windows 10 is indistinguishable. And then you’re Windows-native.

2 Likes

the advantage of using DirectSound is, that it is multithread able, I didn’t get this using WASAPI

example:
when I have VCV open and want to watch a tutorial on YT, no problem with DirectSound
but doesn’t work with WASAPI.

1 Like

FWIW, I run WASAPI and don’t have any problem watching YouTube videos at the same time

1 Like

Also have not got that issue with WASAPI, even with ASIO that does not happen for me and it probably should (exclusive mode).

I remember having that issue with an MBOX 2 then Avid released windows audio drivers that allowed other application other than ProTools to have an audio stream while it was in use. Maybe a similar case?

Thanks all,

I’ve had a bit of a play around with various settings and got it working better - it turns out that using WASAPI instead of ASIO uses ~200mS less, indicating something about the ASIO isn’t 100% right

@Jon I’ve changed both of these, to not very discernible difference. The fuzz audio glitch keeps on happening

@Coirt I’ve double checked and the interface driver from Behringer’s website is the most up to date one. However, I’m still running Rack 0.6.2c, so potentially some of the ASIO drivers are out of date - is that possible? I’m very much a music technology amateur. I shall have to have a look.

@rsmus7 When you say you use DirectSound, how are you getting inputs and outputs to work at the same time? In VCV rack on the Audio module I only have the option for default device (1-2 in, 1-2 out), the Behringer outputs 1-2/3-4, and the Behringer inputs 1-2. On the ASIO “mode” I can use all 4 outputs and 2 inputs simultaneously. While it isn’t a problem not having both outputs available at once, I would like to be able to have inputs and outputs simultaneously. When you say you don’t use the Behringer ASIO driver, does that mean you don’t have it installed at all? Do you have any other drivers installed or not?

@Jon The device will work with WASAPI and that is by far the cleanest sound in terms of lack of glitches - it is comparable with the inbuilt soundcard. However, it only has options for either of the 2 outputs, or the input - never any combination. This is a smidge annoying because I got in primarily so I could process sounds from a mic through Rack live :roll_eyes:

Sorry for another text wall, like I said before I’m probably missing something obvious, but you never know. Thanks again for all of your help, it’s really kind of you to give up some of your time helping me,
Jim

  1. I don’t need more than input 1-2 and output 1-2, so I’m happy with this, but I think I could maybe set up a second Audio8 and rout it to the other ins/outs, tho I haven’t tried it yet.

  2. I have the Behringer ASIO instaled beside some other ASIO drivers, after testing now again, the
    FLStudio ASIO driver works pretty well.

I also cleaned my system from other unused audio drivers/chips.

WASAPI works now as expected too.

If you have a realtech audio chip, I’d recommend to disable it in the device manager. and maybe uninstall realtech drivers for audio.

1 Like

yep it’s now working here too

v1 will probably have better perfromance.

2 Likes

This is a bit of a derailment to your thread, @McMij, but I stumbled across this Microsoft article about low-latency sound in Windows 10 while I was looking for something else. It may be of use to some folks.

EDIT: After some experimenting with another issue, I’ve come to the conclusion that glitch-ery or the lack thereof is more or identical for me on my Windows 10 computer with either WASAPI or ASIO. However, my ASIO driver has less latency per setting than WASAPI.

1 Like

I’ve only just picked up your query
I’m sorry I can’t help/comment on Windows problems as I run a Mac based system which doesn’t need driver installation. However I would say that I have had no problems running this interface in much the same way as you describe in your op. (Solid build and value for money).

1 Like

I’ll have to have a look at that. I’ve spent some time thinking, and it isn’t the interface that is the problem, or the driver, else there’d be a lot more topics like this on the interwebs. It is much more likely to be my bottom of the market HP computer unable - completely understandably - to run VCV and an audio interface with inputs/outputs. This is somewhat confirmed when recording a patch - the audio glitches are recorded, even when using the NYSTHI recorder, which is unusual, but hints that the computer - not the interface - is the problem.

When I’ve it more time I need to do some more experimenting, and try a few other DAWs. This isn’t how i initially intended to use the interface (I was - rather optimistically - going to try to use Rack as a live processor for acoustic instruments), but should work slightly better as it’ll be lighter on the PC.

Thanks again, Jim

Hi I have the UMC2004 also and have had awful driver issues in Windows 10 22H2 . None of the drivers I have tried worked from the latest 5.51 to the oldest . I contacted Behringer and got a weird message back which I didn’t understand: “The issue mentioned within Device Manager is not an indication the driver has installed incorrectly and is nothing to worry about. The exclamation mark/message is usually caused by an additional USB endpoint that is used for firmware updates only on DICE based USB interfaces and will not cause any functional issues.” Well that was meaningless so I uninstalled everything and ran PC HelpSoft Driver Update this said the drivers I was having trouble with the BEHRINGER UMC 204HD 192k Subdevice driver was uptodate with no Behringer software loaded . So now that my mic works i ordered some monitors but am stuck if i run wire from my Main out A or B to my Realtek input this will presumable output the mic to the in on the Realtek. If I run output from Realtek to inserts will this mix out to the monitors ?