Beginner issue: Probably permission issues or similar

Hi All,

I am trying to follow the tutorial. I can use the helper to create a plugin stub and ‘make’ it. But I run into issue when I try to ‘make’ a module.

Any help appreciated

thanks Rob

techb@Hal MINGW64 /g/Development/Rack-SDK-1.1.6/Rack-SDK/MyPlugin (master)
$ make
g++ -std=c++11 -Wsuggest-override  -fPIC -IG:\Development\Rack-SDK-1.1.6\Rack-SDK/include -IG:\Development\Rack-SDK-1.1.6\Rack-SDK/dep/include -MMD -MP -g -O3 -march=nocona -funsafe-math-optimizations -Wall -Wextra -Wno-unused-parameter -DARCH_WIN -D_USE_MATH_DEFINES  -c -o build/src/MyModule.cpp.o src/MyModule.cpp
process_begin: CreateProcess(NULL, g++ -std=c++11 -Wsuggest-override -fPIC -IG:\Development\Rack-SDK-1.1.6\Rack-SDK/include -IG:\Development\Rack-SDK-1.1.6\Rack-SDK/dep/include -MMD -MP -g -O3 -march=nocona -funsafe-math-optimizations -Wall -Wextra -Wno-unused-parameter -DARCH_WIN -D_USE_MATH_DEFINES -c -o build/src/MyModule.cpp.o src/MyModule.cpp, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [G:\Development\Rack-SDK-1.1.6\Rack-SDK/ build/src/MyModule.cpp.o] Error 2


I wonder if it’s just a bad idea trying to develop in windows and I’d be better in ubuntu.

I can see folders being made but not populated.

The folders look read-only but I can’t tell for sure. If I uncheck the folders read-only flag and then return it is re-checked. I also moved from an external harddrive back to documents to remove another permutation.

I bypassed the arch check and hardscoded the four win values

ARCH := win
ARCH_WIN_64 := 1
BITS := 64

because it failed all equality tests and I could find no reference to this method of finding the archecture

MACHINE = $ (shell $(CC) -dumpmachine)

Am I using the wrong compiler perhaps?

Looks like your RACK_DIR is set to the Windows path rather than the msys path. Probably doesn’t understand the “G:”. Try:

export RACK_DIR=/g/Development/Rack-SDK-1.1.6/Rack-SDK/

I do both (ubuntu and win10) and have no problems with either. If you use the documented procedure including the msys2 shell, windows dev for plugins works quite well. It might even be easier in win, because if you use your msys2 install mainly for VCV you will tend to have all the right versions of the packages installed. Every now and then you can get into a fight with ubuntu over which versions of what packages are installed.

1 Like

thanks for the response. I got up real early this morning once I knew I got replies :smile:

I indeed added the path to environment variables thinking msysy shell used them.

exporting the path in mysys instead worked like a charm.

I hope to use both unbuntu and windwoes in the future but right now I’d prefer developing windwoes because I’m using it as my main muisic maker.


You probably have your own preference, but the (free) Visual Studio Code seems to be the preferred code editor. I use it for everything.

1 Like