Beat Step (Non pro) as midi comtroller/transport

I have an OG Beat Step, non pro, just gathering dust. Was thinking to use it for performing. For example, have the stop and play buttons on the BS be the reset and run button in VCV, main knob as master volume, sequencer pads mutes/fades on the mix master, one row of knobs volume on the mixer and another row for controlling perimeters.

I can get the knobs to map but not the buttons. I have seen videos on 1.0 that allow you to use buttons from a keystep pro sequencer to map but nothing really on 2.

Anyone doing something like this?

VCV Midi-Map module maps midi CC’s to module parameters (it doesn’t handle midi note messages). See Beat Step (Non pro) as midi comtroller/transport - #3 by SuperMuppet

Pads send midi notes or CC’s - you can configure the beatstep in their midi control center app.

Yours may be default config - or some customization: you can use stoermelder midi-mon to see what it sends.


Table from the user guide p.37

If you don’t change it from note to cc, you have to use seperate modules for the encoder knobs ([MIDI-MAP)) and pads (Midi-Gate followed by some mapping module from Stoermelder.)

He also has modules that let you use the relative modes of the controller.

I have both the Beatstep and Beatstep pro, but not connected right now.

Yep I use a non-Pro Beatstep quite a lot, usually for triggering looping, and muting/soloing mixer channels. I use Stoermelder Map, click on one of the slots, press the button then click wherever on screen you want it to trigger. After it’s mapped, I change it depending on whether I want it to be momentary or toggle mode.

1 Like

Midi-CAT right ?

Yes, sorry MIDI-CAT, not map! Well spotted, I replied too quickly there :wink:

No worries. It’s good to have the Stoermelder plugin back in the library.

Thanks.

Trying to find which code to change the parameter has been a challenging, 128 different with none staying on that i could find, just a momentary on then off again.

Beatstep can’t do it, it either sends “note on + velocity” or “CC”.

Hers the default for my upper left pad in Midi Control Center.

If it’s set to default for the pads(GATE, sends note ON + velocity + pressure + note off on release) you have to select “Input mode for notes” to “toggle” in the MIDI-CAT module.

1 Like