Bastl Announcements Thread

Annoucing the arrival of the first Bastl module for VCV, Kompas.

Kompas is a three-coordinate probabilistic pattern navigator. Each coordinate has a unique traveling pace and a dedicated trigger output. The amount of probability can be adjusted manually or by external voltages. Once a coordinate has been adjusted, a new pattern is generated and looped until the next change of direction.

manufacturer page: Bastl Kompas Eurorack Module – probability trigger generator


zine: KOMPAS bastl zine by bastl-instruments - Issuu


As for other modules, there are no immediate future plans, but never say never :wink:


Love this. Kompas me up!

Thanks much!

Neat! Why GPL-3.0-only license though? might not be compatible with future versions of VCVRack then (it itself uses GPL-3.0-or-later for forward-compatibility with the GPL)

Amazing, can’t wait to learn this!

Good question. The reason (as I understand it) is that the source on which it is based is CC-BY-SA V4, which is one-way compatible with GPLv3 (but not GPLv3+).

1 Like

Yeah Baby Yeaaah.

Ubuntu 18.04, VCV Rack Free v2.beta.1, GCC 7.5.0

[0.136 warn src/plugin.cpp:173 loadPlugin] Could not load plugin /home/dlphilp/src/Rack2/plugins/Bastl: Failed to load library /home/dlphilp/src/Rack2/plugins/Bastl/ /home/dlphilp/src/Rack2/plugins/Bastl/ undefined symbol: _ZSt28__throw_bad_array_new_lengthv

I get the same error when I try to run the Kirkpatrick Pattern Generator package ($$).

Any comments/suggestions re: a fix ?

Best regards,


Yes, definately don’t run the v2 betas anymore with the plugins now available. Use latest SDK and latest released Rack v2 or compiled yourself. You cannot rely on the betas to be compatible with the SDK and plugin source now online. Also: Completely (!) clear out your …Documents/Rack2/ directory when you have run the betas, before you run the releases, that’'s a must.

1 Like

Ah, good advice. Thanks, Lars, I’ll do that now.

[edit]: What I built from:

commit 9ad53329fff74989daf3365600f9fccc0b6f5266 (HEAD -> v2, tag: v2.0.4, origin/v2)
Author: Andrew Belt <>
Date:   Sat Dec 18 11:41:51 2021 -0500

    Add cleandep target to Makefile.

Which appears to be the latest source commit. Btw, I also update and build all open-source plugins in use on this system. AFAICT everything’s up to date here.

Probably a compiler/library issue.

[edit] Yeh, likely so. VCV Host throws the same error. @cschol told me that the official toolchain uses a version of GLIBC that wasn’t a part of a stock Ubuntu system (well, mine at least). I can 1) switch to using the prefab version of VCV Rack or 2) install the same components in the upstream toolchain and rebuild Rack and its plugins. Both solutions are relatively straightforward, but for the time being I’m going to keep my system as-is. It’s a tool-kit, and for quite a while already it’s been chock full of stuff for me to explore. I’m sure the Bastl module is super-cool, but right now I have a modules collection super-abundant with super-cool stuff, which I shall take off to explore now. :slight_smile: Thanks for the note, Lars !

1 Like

This is great, thanks! Hope to see more Bastl modules in future!

1 Like

Hmm, it doesn’t explicitly say that though. The “or any later version” is something that you have to append explicitly to the GPL. I don’t think this relates to CC in any way.

[edit: ah no, reading here now: ShareAlike compatibility: GPLv3 - Creative Commons

This is really why CC shouldn’t be used for software projects, it causes more problems than it solves :confused:

However, which part that you used is CC-BY-SA V4 then? If it’s just the panel design then this is not related to your code license in anyway.]


Both code (+ modifications obviously) and panel.

1 Like

Ah yes, found the project here: GitHub - bastl-instruments/kompas: Manual, Schematics, Firmware and code examples

Just for pcb designs I guess CC kind of works, but for firmware it’s such a poor substitute :confused:

I know that there are “no immediate future plans” but if you happen to have a list of potential modules then please add Tea Kick and Little Nerd. They’re discontinued anyway, aren’t they? :wink:

And Wackel Kontakt the infamous Broken Cable & Bad Contact Emulator!


Are you trying to run plugins from the Plug-in Manager in your own compiled version of Rack? That will only work if your Rack is compiled with gcc 11 (as the plugins are).

Yes, we discussed this. The error here was different from previous GLIBC version errors, it took a moment before I realized it was still a compiler issue. As I wrote earlier, rebuilding with the required compiler is do-able - or I could just use the available binary - but at this time I’m putting my Rack energies into other concerns. I do prefer to run my own builds, so I’ll avoid downloading from the PM. Thanks for the note, and thank you for all your work on VCV Rack.