bark v1.2.4: clamp update crashing rack

mac sierra vcv rack 1.1.6

opened up a patch that worked before the latest update. patch works fine until i scroll down to the third row or zoom out revealing third row. suspected clamp as it is the only module in that row that is not in the previous rows above. opened a new rack and added a clamp and rack immediately crashed.

need a solution quick. can someone tell me how to de-upgrade?

Fixed in latest version, pushed to library let me know if the issue still exists after the next update.

Unfortunately I am unable to provide a Mac distribution, but if somebody wants to make dist on the latest version of my repo that should fix your issue.

The issue is in Clamp and Trim LFO BPM.

my version is current according to rack updater. is the fix not live yet?

thanks for the quick reply.

The fixed version is not yet released. PM me your patch and I will delete clamp from it so you can open the patch.

is it a matter of deleting it from the txt file version of the patch? there are several patches that are effected by this this need a self reliant solution.

Depending on the amount of instances of Clamp used they would all need to be deleted along with the associated cables which can be found with assigned Clamp(s) ID’s.

Send me whatever patches and I can do this fairly quickly by manually deleting the entries, if you want to try this yourself just be sure to copy the patch first so it opens regularly when the update is live.

I tried doing one myself…yeah thats a little above my pay grade. I’ll PM you the patch and maybe i can derive how to change them correctly by seeing the difference. Hopefully the update goes live soon.

Update is now live so issue should be fixed if it is not let me know!


Seems to be working now. The old patch is working as it was before.