Audio pulse to clock question

Hoping someone can help me figure out a weird issue I have turning an audio pulse into a clock. The goal is to sync clock across two computers running VCV–no DAWs involved–so my buddy and I can play together.

Concept: Buddy’s computer/VCV generates audio pulse from Clocked (e.g., bass drum)…audio goes into my computer/VCV into Hora Follower, which outputs a trigger to run Clocked on my system.

Testing this out just on my own system within one session of VCV…MOSTLY works. The trigger from the Follower can trigger a hihat directly–right on time. BUT…if I take it into another Clocked, it shows up at half the original BPM, and changing the mode doesn’t seem to help. I can’t find what setting I need to change to make it match up. I can always use a clock multiplier before my main clock…but why if I don’t need to. Also, if I adjust the BPM on the original clock, there’s several seconds of lag before the second clock “catches up” and gets in line. Is this just what I should expect, or is there something else I could be doing?

If it is helpful here is a link to a vcv selection that does this.

Please excuse my ignorance…I am just learning.

Thank you!

Audio pulses can be easy to sync to if your interfaces are DC coupled. AC coupling messes up pulse triggers. The envelope follower is OK but maybe a bit too sloppy. There are other ways around sending clocks over audio but I’m not up on them. I think you can use OSC to send sync over internet or wifi but it works best over a net with no other traffic, like jacking bothbcomputers into a router not connected to anything else.

1 Like

You can try skip the envelope follower, send clock trigger from Impromptu Clocked out directly to Impromptu Clocked in.
Make sure both computers are set at same Frequency (ie: 44khz / 48khz) both in their audio interface settings and in the VCV audio engines.

1 Like

You don’t need a DC coupled interface to send audio pulse clocks, as they are just audio like any other audio.

Any interface can send an audio pulse clock, even the basic headphone out on a laptop. The only issue you might run into sometimes, depending on the sensitivity of the device you are sending the clock to, would be related to level - as audio outs are generally line level which is significantly less than modular level. Sometimes you might need to amp the signal a little for some hardware to recognise the pulses but more often than not, line level will be fine - just make sure you have the volume turned up.

No need to start with a clock pulse, use it for a kick, put that through an envelope follower to try and derive a clock pulse from it again, because you’re already starting with a clock pulse - just use that.

As Latif says - all you need do here is connect the audio out of one computer to the audio in of the other and send out a clock from one Clocked directly into the BPM input of Clocked on the other. And make sure everything is running at the same sample rate.

You’ll get best results (faster sync and responsiveness to changes in tempo etc) at faster pulse rates like 24ppqn - so send a x24 output from Clocked, and on the Clocked that is receiving, press the mode button until it says P24 to set it to 24ppqn.

1 Like

Not sure why you deleted your post but yes, like that.

You don’t need to connect Run and Reset across computers - The receiving Clocked will start running automatically as soon as it detects an incoming clock pulse. And in Clocked’s right click menu, you can get it to do Resets automatically when it starts or stops running - experiment to see what works best - I generally find ticking both the reset options for when it stops running works well.

1 Like

OK–that works great! Thank you all! And steve, you guessed exactly why I deleted–cuz I realized I might have trouble with Reset/Run. You’re a mind reader! Thanks!

So, like this? (trying to simulate two computers by going thru a mixer here)

Yep that’s it (other than the Run/Reset thing)

1 Like

I guess the master and slave relationship of Clocked does not work if the two don’t run in the same window/session?

actually–it does. I tested further…disconnected the Reset and Run from each other in the patch above, and made the adjustments Steve recommended with regard to right-click settings on the second clock. Worked great! Now, just need to test on two computers (should work…haha).


Works between multiple devices and platforms simultaneously :+1:t3: